Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed PhpStorm application in my Ubuntu 12.04 but in the Dash Home (and in Dash Bar also) appears a Question Mark icon.

phpstorm icon

I have tried to re-config the shorcut, but it not works (just the icon, the app open when I click it). Here is my *.desktop:

[Desktop Entry]
Version=1.0
Type=Application
Name=JetBrains PhpStorm
GenericName=JetBrains PhpStorm
X-GNOME-FullName=Php Storm PHP IDE
Exec="/opt/PhpStorm/bin/phpstorm.sh" %f
TryExec="/opt/PhpStorm/bin/phpstorm.sh" %f
Icon="/opt/PhpStorm/bin/phpstorm.png"
Categories=Development;IDE;
Terminal=false
StartupNotify=true
StartupWMClass=jetbrains-phpstorm

In /opt/..../phpstorm.png I have my 128x128px icon.

How to show fine my icon??

I also have tried to use xpm icon or the default PhpStorm icon, but it does not works

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I have discovered the reason:

ls -all

drwxr-xr-x  3 root root 4096 nov 10 18:04 google
drwxr-x---  7 root root 4096 nov 11 12:28 PhpStorm
drwxr-xr-x  8 root root 4096 nov 10 21:28 VBoxGuestAdditions-4.2.4

setting up the permissions like the google chrome folder everything works!

drwxr-xr-x  3 root root 4096 nov 10 18:04 google
drwxr-xr-x  7 root root 4096 nov 11 12:28 PhpStorm
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.