Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP Pavilion dv6 with an Nvidia GeForce GT 230M running the privative driver version 304.43 and Ubuntu 12.04 LTS x64.

I am able to clone the screen and use "extended desktop". The problem comes out when I try to use another screen (not the laptop's one) and I close its cover. At this time the other screen turns black and when I reopen the laptop's cover again the login screen appears on the external one.

So my question is very simple: Is there a way that allows you to work with an external screen closing your laptop's cover (as its screen has been already disabled via NVIDIA X Server Settings)? It is possible with Windows, so I guess with Ubuntu too :)

P.S. If I maintain the laptop's cover opened it works fine, it's just a matter of space...

Thanks a lot!

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I finally achieved it some time ago in a very simple way:

Just close your laptop's cover before the OS boots and you are done.

You will be able to disable your laptop's screen and only use your external one.

Cheers!

share|improve this answer

I was having similar issues and found/modified a script that handles the detection of the external monitor for me, so I don't have to manually disable the laptop screen... I have the script running in my startup applications. This is specific to my setup, but used the ARandR app to help me determine the specifics for my monitor (http://www.ubuntugeek.com/arandr-a-simple-visual-front-end-for-xrandr.html)

#!/bin/bash
sleep 5
XRANDRexternal="xrandr --output HDMI1 --off --output LVDS1 --off --output DP1 --set audio off --mode 2560x1600 --output VGA1 --off"
XRANDRnoexternal="xrandr --output HDMI1 --off --output LVDS1 --mode 1280x800 --pos 0x0 --rotate normal --output DP1 --off --output VGA1 --off"
if xrandr | grep -q ' connected'
then
${XRANDRexternal}
else
${XRANDRnoexternal}
fi
share|improve this answer

You should have a look at the power management, and change the options so the computer doesn't hibernate when the screen is closed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.