Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I purchased an HP laptop with the Qualcomm Atheros AR9565 (QCWB335) wireless adaptor. I understand that this adaptor is currently not supported on Ubuntu 12.04 and there is no way to get wireless access.

I installed compat-wireless-3.6.6-1 ath9k driver and it didn't work: lshw -C network still showed *-network UNCLAIMED after reset.

How can I figure out when Ubuntu will have driver for AR9565? Is there a workaround to get wireless working somehow?

I need to figure out whether to return the laptop or wait it out.

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

Your device is covered in this package: http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2

The files with extra letters, in this case snpc, are pre-patched to add newer devices and, sometimes, features. Yours is a good example.

share|improve this answer
    
This worked. After installing the updated Ubuntu driver, my wireless adapter appeared, but was hardware disabled. I had to install Windows 7 in a side partition and get the Wireless working there first. Then, after I booted into Ubuntu, wireless was working. –  Victorb Nov 20 '12 at 14:19
    
Very glad it's working. Don't forget to re-compile after a later kernel version is installed by Update Manager. –  chili555 Nov 20 '12 at 16:44
add comment

The compat-wireless package will probably require adding your pci.id to the pci.c file as well as some other changes, similar to this: http://ubuntuforums.org/showpost.php?p=12201881&postcount=35

Did you do that? Learn your pc.id with:

    lspci -nn | grep 0280

There may be a version of compat-wireless that includes your device. If you'll post the details, we'll be happy to assist you.

share|improve this answer
    
I did not make any custom modifications to the code yet. I'm guessing the pci.id for my device is 36 from 0a:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0036] (rev 01). It is currently not in the ath_pci_id_table. I'll try to add it and see what happens. –  Victorb Nov 11 '12 at 15:50
    
After adding 36, the wireless is still not working as before. It is still UNCLAIMED. The only change I see is that the wireless light is always red on my laptop (off). I cannot make it white by pressing Fn-F12. However, doing sudo rfkill list all shows that nothing is blocked. –  Victorb Nov 11 '12 at 20:30
add comment

I was able to fix this issue by running the following commands.

sudo apt-get autoclean
sudo apt-get update
sudo apt-get dist-upgrade

What I found that this upgrades the kernel from 3.2.0.56-generic to 3.2.0.57-generic.

Hope that helps...

share|improve this answer
add comment

Qualcomm Atheros QCA8172 on Lenovo G505 - Ubuntu 13.04 works perfectly on Lenovo G505 - make sure you do a clean install of Ubuntu 13.04 vs a 're-install'. Wi-Fi/LAN keyboard mouse everything works perfectly.

I'd spent all day looking for drivers, but the ones included in ubuntu 13.04 already support Qualcomm Atheros QCA8172 network driver card. Cheers

share|improve this answer
5  
The question is about the AR9565 (QCWB335) device. You're describing another one, so this does not apply here, unless you can show that the support for the one in the OP is also available in 13.04 now. –  gertvdijk Aug 22 '13 at 5:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.