Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello i have problem with my driver.

What i did,

$ sudo apt-get update
$ sudo apt-get install ia32-libs-multiarch i386 lib32gcc1 ia32-libs libc6-i386 ia32-libs
$ sudo sh amd-driver-installer-catalyst-12.11-beta-x86.x86_64.zip --buildpkg Ubuntu/quantal
$ sudo dpkg -i fglrx_9.010-0ubuntu1_amd64.deb
$ sudo dpkg -i fglrx-dev_9.010-0ubuntu1_amd64.deb
$ sudo dpkg -i fglrx-amdcccle_9.010-0ubuntu1_amd64.deb 
$ sudo aticonfig --initial
$ sudo reboot

After reboot

$ fglrxinfo

And i get

X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  17
  Current serial number in output stream:  18

:_(

Here are my logs

media.cdn.ubuntu-de.org/forum/attachments/08/45/5006157-Terminal_log.txt

media.cdn.ubuntu-de.org/forum/attachments/08/45/5006157-Xorg.0.log

media.cdn.ubuntu-de.org/forum/attachments/08/45/5006157-Xorg.0.log.old

Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed.

My PC

Mainbaord:Z77A-G14

GPU:AMD/ATI HD5850

Festplatte:596GB Western Digital

RAM:18,0 GB Dual-Kanal DDR3

CPU:Intel Core i7 3770

share|improve this question
    
Have you installed the linux-headers package corresponding to your linux-image version? –  Michele Nov 16 '12 at 21:01
add comment

2 Answers 2

I'm no expert but the last time I installed ATI drivers on an ubuntu machine I ran into a similar problem. It turned out I didn't have the kernel headers installed. grabbed the headers and the kernel module compiled no problem.

also, from the post you made it looks like you were trying to prepare the machine for a 32 bit driver build, is there any reason you're installing these:

sudo apt-get install ia32-libs-multiarch i386 lib32gcc1 ia32-libs libc6-i386 ia32-libs

to install a 64 bit package?

share|improve this answer
    
Ok i found ubuntu-forum.de/post/349831/… :) –  Liukas Miklia Nov 14 '12 at 8:30
add comment

Hi I'm fairly new to both Ubuntu and askubuntu.com. What I did was to download the beta drivers from here: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx

Then I right-clicked on the file, under permissions made sure it's marked as an executable, double-clicked it and chose "Run in terminal". The rest is pretty much straight forward.

As a side-note, if you want to remove the water mark (AMD for testing only) that appears after you installed the drivers - just follow this video: http://www.youtube.com/watch?v=OcNDyYozzrQ

If you look in the comments of the video you will see what I had to do to make the script work. I hope I don't offend you by my very newbie-like approach. You can always just ignore me and wait for more advanced terminal magic suggestions ;)

EDIT: Just realized that if the old drivers give you problem, run these commands in the Terminal:

sudo sh /usr/share/ati/fglrx-uninstall.sh 
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.