Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Lately, I've been having Ubuntu crashing randomly.. it goes into read only mode, but once I restart it's working again.

Today it happened again and I had to manually shut the computer down.

Now I'm not able to boot anymore. I get the following when turning the computer on:

error: unknown filesystem

And I'm left at "grub rescue".

I booted from the Live CD and installed "boot-repair". When I run it it says "no os has been found on this computer", it gives me no option to carry out any fixes.

Boot Repair generated the following output which shows some errors: http://paste.ubuntu.com/1348224/

Any idea on how to fix this?

** UPDATE: FIXED! :) *

running: sudo fsck /dev/sda1 brought a list of errors within that partition, I selected "yes" for fixing each one of them.. it was a long list of directories, inodes, files.. after finishing I restarted the computer and it booted in Ubuntu as if nothing had ever happened!

share|improve this question
    
Did you tryed this: grub-install --recheck /dev/sda ? –  Zero Nov 10 '12 at 16:52
    
should I run that from the terminal in the Live CD? –  user1189907 Nov 10 '12 at 16:55
    
just run it from live CD and got: "/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?)" –  user1189907 Nov 10 '12 at 16:57
    
In terminal afcourse. –  Zero Nov 10 '12 at 16:57
    
yeah I asked because thought it could be in the "grub rescue" command line.. first time that I get stuck like this outside of my system :S –  user1189907 Nov 10 '12 at 17:02
show 2 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.