Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I install any of the proprietary NVIDIA drivers (nvidia-*) from the repositories, Unity does not load after I log in. I just get a blank desktop background with no icons, panels or launchers.

If I uninstall the drivers again, the desktop does load properly, but then certain games don't work correctly.

Is there any way to resolve this? Thanks.

share|improve this question

2 Answers 2

I had this happen to me on Ubuntu 14.10 x86_64 with kernel 3.16.0-28 after loading Nvidia 346 drivers. After login I would get the blank Ubuntu background wallpaper and nothing else, no way to do anything. There are many similar problems posted online over the past four years; most of the solutions did not work for me. Attempting to restart unity I got an error: compiz: plugin OpenGL not loaded.

Finally, this is what worked:

CTRL-ALT-F3 < ...to reach console, and then login. >
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
sudo killall nvidia-persistenced
sudo apt-get purge nvidia*
 < see the error message, and get the process ### >
sudo kill -9 ###  
  < ... ### is from previous error; a process locking user "nvidia-persistenced" >
sudo apt-get purge nvidia*
sudo apt-get install nvidia-prime
sudo reboot

 < ...wait... >
CTRL-ALT-F3 < ...to reach console, and then login. >
export DISPLAY=:0
sudo dconf reset -f /org/compiz/
gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins
  <...note space after 'core/' and before 'active-plugins'  >
sudo reboot

...and then it worked. Would love not to have to go through that again!

See also: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1166765 and https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1342339

share|improve this answer

1st option: Download drivers from http://nvidia.com/object/unix.html, not from repos. After installing restart computer.

2nd option: Restart computer after installing nvidia drivers from repos.

share|improve this answer
    
Rebooting makes no difference. I would rather not use the command-line installer if at all possible, since the .debs are easier to keep up-to-date. –  afeder Nov 10 '12 at 17:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.