Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running Ubuntu 9.10 (Karmic Koala) with no problems. I recently upgraded to Ubuntu 10 (Lucid Lynx) and cannot use it normally. After I log in, the screen scrambles (a purple/green mess)--impossible to see anything, although I can get out by marking the spot on the screen to click for a restart, so Linux is working behind the scenes.

If I start in recovery mode with basic graphics, I have no problems at all (other than limited functionality). If I start the old 2.6.31-22 kernel, I see a bunch of "unmountable" errors in the startup script, but I can use Linux normally with no apparent problems. I'm running an IBM ThinkPad A30 with ATI Mobility graphics. Just to reiterate, the screen looks normal until I log in, at which point it goes bonkers.

What do I need to change in order to fix this?

share|improve this question
1  
Before upgrade did your have proprietary fglrx driver or radeon? If first, how did you install it? –  Takkat Jan 14 '11 at 17:25
    
I'm sure it's not proprietary--I just used all default drivers when I installed Ubuntu 9. –  Matthias Jan 18 '11 at 22:44
add comment

1 Answer 1

and thanks. The solution was actually a very simple update to the grub file, which I found in the release notes for 10.04.

Working around bugs in the new kernel video architecture

Ubuntu 10.04 LTS enables the new kernel-mode-setting (KMS) technology by default on most common video chipsets. While this is a major step forward for the graphics architecture in Ubuntu, in some rare cases KMS will prevent your video output from working correctly, or from working at all. If you need to disable KMS, you can do so by booting with the nomodeset option. You can also save this setting so that it's applied at every boot by adding it to your grub config

For GRUB 2: (The Default)

Edit /etc/default/grub and add nomodeset to GRUB_CMDLINE_LINUX.

Then run sudo update-grub;

For GRUB 1:

edit /boot/grub/menu.lst and add nomodeset to the line beginning with # kopt=,

Then run sudo update-grub).

I'm not sure what KMS does, but it sure screwed up my display. Adding the "nomodeset" boot command fixed everything!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.