Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am just setting up a new install of Ubuntu 12.04.1 x64

I need to log on to my workplace citrix so installed the icaclient. Unfortunately I accidentally clicked the i386 file first time around instead of the AMD64 version on the citrix download page. Software manager tried to install it anyway. it did not show up as installed after it failed so I proceeded with the AMD64 install.

at the end of the install I got a similar error output to the one below. I closed it and proceeded to see if it had installed. All works fine - no problem logging on to citrix server.

The problem is that all subsequent installations with software manager is producing the same error as below. This last one is following installation of HPLIP Toolbox.

But all the apps so far install work so the problem cant be too serious, just very anoying and puzzling.

Can anyone please advise what the problem is and how to fix this? Should I un-install icaclient completely via software manager and start again or will this miss the erroneous i386 packages? Is there a way to purge the i386 stuff without affecting the AMD64 packages?

Its a shame not to have a new install not working perfectly :-(

installArchives() failed: Selecting previously unselected package libqt4-designer.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 173813 files and directories currently installed.)
Unpacking libqt4-designer (from .../libqt4-designer_4%3a4.8.1-0ubuntu4.3_amd64.deb) ...
Selecting previously unselected package libqt4-help.
Unpacking libqt4-help (from .../libqt4-help_4%3a4.8.1-0ubuntu4.3_amd64.deb) ...
Selecting previously unselected package libqt4-scripttools.
Unpacking libqt4-scripttools (from .../libqt4-scripttools_4%3a4.8.1-0ubuntu4.3_amd64.deb) ...
Selecting previously unselected package libqt4-test.
Unpacking libqt4-test (from .../libqt4-test_4%3a4.8.1-0ubuntu4.3_amd64.deb) ...
Selecting previously unselected package libqtassistantclient4.
Unpacking libqtassistantclient4 (from .../libqtassistantclient4_4.6.3-3ubuntu2_amd64.deb) ...
Selecting previously unselected package libqtwebkit4.
Unpacking libqtwebkit4 (from .../libqtwebkit4_2.2.1-1ubuntu4_amd64.deb) ...
Selecting previously unselected package python-sip.
Unpacking python-sip (from .../python-sip_4.13.2-1_amd64.deb) ...
Selecting previously unselected package python-qt4.
Unpacking python-qt4 (from .../python-qt4_4.9.1-2ubuntu1_amd64.deb) ...
Selecting previously unselected package python-qt4-dbus.
Unpacking python-qt4-dbus (from .../python-qt4-dbus_4.9.1-2ubuntu1_amd64.deb) ...
Selecting previously unselected package hplip-gui.
Unpacking hplip-gui (from .../hplip-gui_3.12.2-1ubuntu3.1_all.deb) ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Setting up icaclient:i386 (12.1.0) ...
dpkg: error processing icaclient:i386 (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up libqt4-designer (4:4.8.1-0ubuntu4.3) ...
Setting up libqt4-help (4:4.8.1-0ubuntu4.3) ...
Setting up libqt4-scripttools (4:4.8.1-0ubuntu4.3) ...
Setting up libqt4-test (4:4.8.1-0ubuntu4.3) ...
Setting up libqtassistantclient4 (4.6.3-3ubuntu2) ...
Setting up libqtwebkit4 (2.2.1-1ubuntu4) ...
Setting up python-sip (4.13.2-1) ...
Setting up python-qt4 (4.9.1-2ubuntu1) ...
Setting up python-qt4-dbus (4.9.1-2ubuntu1) ...
Setting up hplip-gui (3.12.2-1ubuntu3.1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 icaclient:i386
Error in function: 
Setting up icaclient:i386 (12.1.0) ...
dpkg: error processing icaclient:i386 (--configure):
 subprocess installed post-installation script returned error exit status 2
share|improve this question

2 Answers 2

Yes, you need to remove the icaclient first, you can either do this with sudo apt-get remove icaclient or you might need to manually remove it with dpkg.

After that is done, you can continue upgrading/installing, and then install the proper package. Then follow these directions to remove the i386 packages:

share|improve this answer
    
Hi Jorge I tried apt-get and dpkg and got the following: –  sean farley Nov 10 '12 at 20:45
    
sean@sean-P55-USB3:~$ sudo apt-get remove icaclient [sudo] password for sean: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? sean@sean-P55-USB3:~$ sudo dpkg --remove icaclient:i386 dpkg: error: dpkg status database is locked by another process sean@sean-P55-USB3:~$ –  sean farley Nov 10 '12 at 20:46
    
Removed using purge command. Reinstalled and got this:..... (Reading database ... 100% (Reading database ... 179390 files and directories currently installed.) Preparing to replace icaclient 12.1.0 (using .../tmp/icaclient_12.1.0_amd64.deb) ... Unpacking replacement icaclient ... Setting up icaclient (12.1.0) ... dpkg: error processing icaclient (--install): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: icaclient –  sean farley Nov 12 '12 at 7:53
    
installed gimp via software manager got this again....Setting up icaclient (12.1.0) ... dpkg: error processing icaclient (--configure): subprocess installed post-installation script returned error exit status 2 –  sean farley Nov 13 '12 at 7:44
up vote 0 down vote accepted

This is solved now. The problem was actually two problems. I cleared out the icaclient problem although this was initially stalled by the second problem which was an uncompleted install of playonlinux via apt-get. I had not figured how to accept the MS ttf EULA in the terminal. which for info is done by using tab to select then hit space to excecute.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.