Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 10.04. I'm affraid I've installed a virus on my computer (I've clicked a link which was a virus), I'd prefere to check if everything is fine.

I've installed clamAV using Synaptic. The installed version was 0.96.5, while the most recent version is 0.97.6. When I was trying to update virus database, I got a warning that the version of clamAV I'm using is outdated. Since I didn't know how to update the software by Synaptic or apt (both show the installed version as the newest) I've uninstalled all and downloaded the recent version from sourceforge. I've unpacked the tar.gz archive, entered the folder but when I type

./configure

I'm getting the message:

configure: error: Please install zlib and zlib-devel packages

When I type

sudo aptitude install zlib zlib-devel

The terminal output says there is no such packages (there is no package zlib-devel and there is many packages which name contain zlib).

I suppose the link contained probably the Windows virus, but I'd prefere to make sure there is nothing in my computer. As well as I'm not sure if the virus, even without harming my system, can send itself to my e-mail contacts or not.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Searching for solution, I've followed the thread How do I enable the "backports"repository? and it helped, the recent version of clamAV began accesible through apitiude tools.

share|improve this answer
add comment

My opinion is to install clamav, from ubuntu packages, with the following:

sudo apt-get install clamav clamav-daemon clamav-freshclam

To update clamav:

sudo freshclam -v

If Updating the Clamav failed with error message try the following:

In Terminal:

Stop the updater:

sudo /etc/init.d/clamav-freshclam stop

Update:

sudo freshclam -v

Start the updater:

sudo /etc/init.d/clamav-freshclam start

http://www.iasptk.com/ubuntu/19931-ubuntu-1204-clamav-problem-with-updating

share|improve this answer
add comment

I could not install clamav as package, because I need to compile it for Zimbra. So I found a solution:

You must install zlib1g-dev package. Try this:

sudo apt-get install zlib1g-dev
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.