Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The keys to set the screen brightness work properly but everytime I reboot, the screen brightness is reverted to 100%, which is very annoying.

I've already tried to add the following lines to /etc/rc.local but with no success (only the keyboard backlight stays off):

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo '1' > /sys/devices/platform/applesmc.768/leds/smc::kbd_backlight/brightness

echo '6' > /sys/class/backlight/acpi_video0/brightness

rfkill block bluetooth

exit 0`

This worked for me when I was using Ubuntu 12.04 and also did after the upgrade to 12.10 but then after rebooting the screen brightness always reverted to 100%. Would be nice if anyone knows how to fix this.

My device: Macbook Pro 13" Late 2011

Thanks in advance!

share|improve this question
add comment

2 Answers 2

Please do double check to see if that directory exists.
You can do so by repeatedly going deeper into the directory using cd and ls.
For instance, cd /sys would get you into the /sys directory and ls would list whatever is in it.
For me, the above mentioned brightness controls are in /sys/class/backlight/apple_backlight/brightness, so in my case, its echo '5' > /sys/class/backlight/apple_backlight/brightness

share|improve this answer
add comment

This is more for the sake of others reading this question because I can see how old your question is. I was able to get the set screen brightness to work by setting the values of both /sys/class/backlight/acpi_video0/brightness and /sys/class/backlight/intel_backlight/brightness.

I was trying to set both of them individually to see if one worked, I'm pretty sure just setting acpi_video0/brightness used to work before 13.04 but since I've updated I've been having trouble.

I would think that both values need to be the same so make sure to check the values you want are correct (acpi_video0/brightness is from 0 - 15 and intel_backlight/brightness is from 0 - 1808). For the record I am running Ubuntu GNOME 13.10 on the same model of macbook pro (8,1).

So for me I have it booting with a brightness of 3 so acpi_video0/brightness has a value of 3 and intel_backlight/brightness has a value of 357. Just set the screen to the brightness you want and check the intel_backlight/brightness to find the value you need to use.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.