Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am receiving the following message while I am trying to install Skype:

nidhin@ubuntu:~$ sudo apt-get update
nidhin@ubuntu:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin but it is not installable
E: Unable to correct problems, you have held broken packages

How can I fix this?

share|improve this question
Try this: ! It fixed the problem for me. – user113777 Dec 10 '12 at 8:23

10 Answers 10

12.10 and newer

I'd the same issue and what helps me was to enable the 32-bit architecture by:

sudo dpkg --add-architecture i386
sudo apt-get update

then I was able to install skype via the Canonical Partner Repository:

sudo add-apt-repository "deb $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

and also via direct skype download:

sudo dpkg -i skype-ubuntu*.deb

I hope that help someone.

share|improve this answer
lsb_release -sc - learn something new every day – user51157 Apr 21 '15 at 19:48
still getting the same error. skype-bin – SY_13 Feb 27 at 7:30

First of all you have to enable i386 architecture before running the below commands on your Ubuntu 64 bit system.

sudo dpkg --add-architecture i386

Then run the below commands on terminal to install skype.

Ubuntu 13.10

sudo sh -c "echo 'deb saucy partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype

Ubuntu 14.04

sudo sh -c "echo 'deb trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
share|improve this answer
if it still shows the error skype : Depends: skype-bin after following this answer, choose a diffrent download server from software and updates. – Avinash Raj Apr 20 '14 at 16:00
Should one remove the i386 architecture after installing Skype? Would the x64 and x86 architectures in dpkg muck things up later on? – blong Aug 11 '15 at 3:50

I suggest to remove skype-bin first completely and install Skype as follows.

Run following commands in Terminal

sudo apt-get remove skype skype-bin

sudo apt-get install libxss1  


sudo dpkg -i skype-ubuntu*.deb
share|improve this answer

skype is not from is a third party software supported by canonical foundation so edit your source.list using

$sudo gedit /etc/apt/source.list

then add the following link into your source list

deb $(lsb_release -sc) partner
deb-src $(lsb_release -sc) partner

$(lsb_release -sc) replace with your ubuntu name. Save it. Then update your repository using

$sudo apt-get update

now run the following command to install skype

$sudo apt-get install skype

this will install skype and skype.bin.

share|improve this answer

Heres how I did it with no issues, skype is working great.

sudo apt-get install skype-bin skype

share|improve this answer
Welcome to Ask Ubuntu! I think this is unlikely to work for the problem described in this question. A not installable error won't go away just by manually indicating the skype-bin package for installation. If you did experience this same problem and this solution did work for you, that's unusual, and I recommend editing your answer to provide some additional information. – Eliah Kagan Dec 25 '12 at 4:31

Try these commands:

sudo apt-get install libxss1 
cd /tmp 
sudo dpkg -i skype-ubuntu*.deb


share|improve this answer
  1. download skype package from here
  2. install it with double-click
  3. open nautilus in /usr/share/applications/
  4. edit skype.desktop (fix for sound issue) and replace line:
    Exec= skype %U with Exec=env PULSE_LATENCY_MSEC=30 skype %U

  5. drag skype.desktop and drop on unity bar (this will make opening same skype instance after closing window)

Full code for the .desktop file can be found at: skype.desktop

share|improve this answer
Additionally, if you want the sound issue fix also when starting Skype via the Alt+F2 mini-terminal and typing skype, do this: create an executable file /usr/local/bin/skype with first line #!/bin/bash and next line env PULSE_LATENCY_MSEC=30 /usr/bin/skype. Make sure with which skype that the skype command now refers to your new file. – tanius Feb 19 '14 at 1:18

This is common problem in 64 bits for installing Skype

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like
sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences

Now download Skype From Official website( ) for multi architecture

then open the downloded package from software center then you should able to install skype

share|improve this answer

Install Synaptic if you don't have it, Open it, then go to Edit > Fix Broken Packages. After that try to install Skype.

share|improve this answer
Thank you for the suggestion..I have done as you suggested however I am still getting the same error message – Nidhin Nov 10 '12 at 9:45

I found the solution to this problem from a different post.

First a downgrade is required and done with the following:

create the preferences file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=quantal*
Pin-Priority: 2012

enter :wq to write the file. Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

That's it.

Now use

sudo apt-get install Skype

And it works!

share|improve this answer
I pity the poor n00b that will copy-paste (or select and middle-click, if he's advanced) this into the terminal w/o a second thought about what he's doing... – YatharthROCK Apr 3 '14 at 15:37

protected by Avinash Raj Jul 16 '14 at 12:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.