Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Modem will not respond in Efax-gtk or in Minicom after initialization.

This modem works fine in Windoze, SAME machine, just switched to Ubuntu 12.04 drive by mechanical switch. I can go back and forth, always works in Windoze, never in Ubuntu.

Modem will attempt to answer an incoming call, but can't be sure about function since I don't have another modem to call with.

In minicom:

Welcome to minicom 2.5
OPTIONS: I18n 
Compiled on May  2 2011, 10:05:24.
Port /dev/ttyS4
Press CTRL-A Z for help on special keys

Nothing further will be shown, no matter what keyboard input, etc. - except it will respond to Ctrl-A and Z, which are not modem responses

IN EFAX-GTK :

efax-0.9a: 21:27:23 opened /dev/ttyS4

Then try to send and wait 5 minutes - no result, so press "Stop":

efax-0.9a: 21:27:46 failed page /home/roger/Documents/Libre Office/Saddleback Labs Request.pdf.001

modem info ttyS4:

*-pci
description: PCI bridge
product: Integrated Technology Express, Inc.
vendor: Integrated Technology Express, Inc.
physical id: 0 bus info: pci@0000:03:00.0
version: 30 width: 32 bits clock: 33MHz
capabilities: pci pm subtractive_decode bus_master cap_list
resources: ioport:d000(size=4096)
memory:f7d00000-f7dfffff

*-communication
description: Serial controller product: 56K FaxModem Model 5610
vendor: 3Com Corp, Modem Division
physical id: 1 bus info: pci@0000:04:01.0
version: 01 width: 32 bits clock: 33MHz
capabilities: pm 16550 cap_list
configuration: driver=serial latency=0
resources: irq:17 ioport:d000(size=8)

roger@roger-desktop:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.
Modem Port Scan<*1>: S0 S1 S2 S3
ttyS4<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS4<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS4<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S5 S6 S7 S8
Modem Port Scan<*1>: S9 S10 S11 S12 S13 S14 S15 S16
Modem Port Scan<*1>: S17 S18 S19 S20 S21 S22 S23 S24
Modem Port Scan<*1>: S25 S26 S27 S28 S29 S30 S31
Sorry, NO MODEM WAS DETECTED! Is it in use by another program? - (my caps)
Did you configure it properly with setserial?

OK, so Ubuntu finds the modem, but doesn't find it!? Which is correct?

I'm almost ready to believe it's a kernel problem, except not by intent. I can't imagine anyone would intentionally screw that up thinking it's best for the world...

I'm NOT trying to connect to an ISP right now, I want to use it with eFax-GTK.

It worked on 12.04 before one of the later updates which included Ubuntu segments as well as others. Then it just quit.

share|improve this question
    
I am a member of dialout group and all others I could think of that might affect this. –  Roger Davis Nov 10 '12 at 5:47
    
Have you tried to run setserial? Is there anything in the output of dmesg? –  qbi Jan 19 '13 at 20:48
    
roger@roger-desktop:~$ sudo dmesg|grep tty [sudo] password for roger: [ 0.000000] console [tty0] enabled [ 1.365228] 0000:04:01.0: ttyS4 at I/O 0xd000 (irq = 17) is a 16550A roger@roger-desktop:~$ –  Roger Davis Jan 20 '13 at 20:11
    
sudo ls -al /dev/ttyS? crw-rw---- 1 root dialout 4, 64 Dec 28 08:20 /dev/ttyS0 crw-rw---- 1 root dialout 4, 65 Dec 28 08:20 /dev/ttyS1 crw-rw---- 1 root dialout 4, 66 Dec 28 08:20 /dev/ttyS2 crw-rw---- 1 root dialout 4, 67 Dec 28 08:20 /dev/ttyS3 crw-rw---- 1 root dialout 4, 68 Dec 28 08:20 /dev/ttyS4 crw-rw---- 1 root dialout 4, 69 Dec 28 08:20 /dev/ttyS5 crw-rw---- 1 root dialout 4, 70 Dec 28 08:20 /dev/ttyS6 crw-rw---- 1 root dialout 4, 71 Dec 28 08:20 /dev/ttyS7 crw-rw---- 1 root dialout 4, 72 Dec 28 08:20 /dev/ttyS8 crw-rw---- 1 root dialout 4, 73 Dec 28 08:20 /dev/ttyS9 –  Roger Davis Jan 20 '13 at 20:13
    
roger@roger-desktop:~$ sudo setserial -av /dev/ttyS4 [sudo] password for roger: /dev/ttyS4, Line 4, UART: 16550A, Port: 0xd000, IRQ: 17 Baud_base: 115200, close_delay: 50, divisor: 0 closing_wait: none Flags: spd_normal skip_test roger@roger-desktop:~$ –  Roger Davis Jan 20 '13 at 20:14

1 Answer 1

You can install software wvdial and gnome-ppp to using usb modem

sudo apt-get install wvdial && sudo apt-get install gnome-ppp

it so easy

share|improve this answer
    
I need to use the existing internal modem, just like Windoze does. The external USB modem is not an answer for me. –  Roger Davis Aug 7 '13 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.