Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running a fresh install of Ubuntu 12.10 with Cinnamon,

after roughly 10 minutes the screen turns black. I have set "Turn screen off when inactive for:" to "Never" or tried high values (1h +), this does not affect this behaviour. In the dconf-editor I located following entries:

org.gnome.settings-daemon.plugins.sleep-display-ac

setting to 0 did not have any effect

org.gnome.desktop.applications.screensaver.idle-activation-enabled

unsetting/unchecking did not have the desired effect

org.gnome.desktop.applications.session.idle-delay

setting it to 0 or very high values (100k) did not have any effect.

do you have any suggestions on how to approach this issue? cheers peter

share|improve this question
    
Cinnamon uses Gnome 3, whereas I believe the system settings you are altering are for compiz/Unity. I think Gnome still uses the power settings for things like screen blanking so you might want to investigate that. –  fabricator4 Nov 10 '12 at 21:53
add comment

4 Answers

Using the GUI look for "Preferences > Brightness and Lock". Or run

gnome-control-center

then choose "Brightness and Lock".

share|improve this answer
    
The GUI "Brightness and Lock" did have no effect on the problem in cinnamon. (As mentioned above - albeit not as clearly as I could have) Nor did the settings in ... plugins/power or session. –  peter Nov 13 '12 at 8:56
    
That's a pity. It definitely works for me, using Cinnamon 1.6.6 on Ubuntu 12.04. –  xebeche Nov 13 '12 at 9:08
add comment

Easiest way to disable screen blanking is to remove the Gnome screensaver by issuing this command:

sudo apt-get remove gnome-screensaver
share|improve this answer
add comment

Unfortunately I lack sufficient reputation to comment or vote up/down, but I can apparently give a separate answer--go figure. Summary: the only fix that WFM was xscreensaver. Details:

My own experience, today, with my GF's ubuntu 12.10 with cinnamon, was as follows:

  1. In the past I had disabled screen blanking on inactivity by using dconf-editor to unset the proper key. I forget the name of that key :-) but it was something like the org.gnome.desktop.applications.screensaver.idle-activation-enabled
  2. This week, I installed the updates requested by Software Updater, which I noticed included cinnamon packages. GF then complained that web videos went black after 10 minutes play.
  3. I applied my previous fix with dconf-editor, restarted (just in case :-), and played video: no fix. I tried a few other dconf-editor hacks: all failed (with increasing irritation).
  4. DuckDuckGo delivered me to this page.
  5. I tried setting mainmenu>Preferences>Brightness and Lock appropriately, restarted (JIC), and played video: no fix.
  6. I tried uninstalling gnome-screensaver): it was not installed. Instead I uninstalled cinnamon-screensaver, restarted (JIC), and played video: no fix.
  7. I thought the xscreensaver answer sounded pretty dubious, but tried it anyway: installed, restarted, configured (via mainmenu>Preferences>Screensaver), and played video: it worked! Hour video stream played without blanking. Thank you, peter.
share|improve this answer
add comment
up vote 0 down vote accepted

I found a dirty workaround in some fedora forum. http://forums.fedoraforum.org/showthread.php?t=269183

  1. install the package xscreensaver
  2. set the screensaver to run after minutes of inactivity=0 (i.e., never)
  3. add the screensaver to the startup applications /usr/bin/xscreensaver -no-splash

this worked in cinnamon.

the other approaches mentioned above only worked with unity

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.