Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Inspiron 9400 with an NVidia GeForce Go 7900 GS video card.

After upgrading from 12.04 to 12.10, my video brightness decreased to the point where I can hardly read the screen. I have attempted to change the drivers using Settings, but none work.

Any ideas would be greatly appreciated.

share|improve this question
    
do the hotkeys to increase/decrease brightness work? –  Daniel Nov 9 '12 at 19:16
    
Hi Daniel, no they don't. Up in the right hand corner, it shows that the brightness is far to the right (highest brightness) when using those keys. I am using the Fn keys and the up and down arrow keys on the lower right portion of the keyboard. –  Bruce Nov 9 '12 at 22:48
    
it looks like the upgrade to 12.10 somehow killed your video drivers. How did you install the nvidia drivers? Did you download the installer from their website or did you use the 'Additional Software' function in 'System Settings'? –  Daniel Nov 13 '12 at 10:33
add comment

3 Answers

Same here for GeForce 330m, 12.10 update killed open source drivers, I am no longer able to adjust screen brightness via Fn + +/-

I believe that can help: How do I downgrading nvidia drivers in 12.04?

share|improve this answer
add comment

Hi chaps hopefully this will help you. I installed Ubuntu 12.10 on my Dell Inspiron 9400 on Monday evening, and I love it but have been squinting at the screen just like you probably are!

This fix worked for me: sudo apt-get remove nvidia-current sudo apt-get install nvidia-current

Then I rebooted.

If that doesn't work more info here: Ubuntu 12.10 won't display properly after kernel upgrade

share|improve this answer
add comment

I have a dell xps 1710 with the same GeForce Go 7900 GS card. After a lot of experimenting I have found a working combination. You have to select the 3.5.0.18 linux-image kernel package. So uninstall all generic or other kernel packages and use the nvidia-experimental-304 driver from the additional drivers tab in the software sources. This works with me.

The proprietary drivers of nvidia do not build with the 3.7 kernel that is now current as generic kernel. And as you have seen the nouveau driver keeps the screen in very low brightness.

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.