Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new laptop with a centrino wireless card.

I installed ubuntu on it and all seemed fine until I upgraded the kernel, and rebooted.

My wireless stopped working despite toggling the wireless button.

rfkill list returns the following:

0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1:hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

the hardware switch only toggles the hard blocks.

How do I turn off the software blocks? I have tried

rfkill unblock all 

without success. What next?

share|improve this question
    
This might help. Also, please mention which laptop you are using? –  green7 Feb 15 '13 at 4:15
add comment

1 Answer

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf
In that config file, just add
blacklist acer-wmi

Just use these commands and reboot. thats it

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.