Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated to Ubuntu 12.10 but now LaTeX doesn't work any more. Kile always asks me "did you run LaTeX?". I'm quite new in this stuff, so it seems a bit strange for me, because in 12.04 it worked always without any exception. I also tried it with other Editors, but there were similar mistakes, so I guess it is related to the upgrade. Perhaps anybody of you has a hint.

share|improve this question
1  
Have you tried running it through LaTeX instead (ie using the command line): pdflatex /path/to/your/file.tex?. This should help to identify if the source of the problem is LaTeX or Kile. –  Salem Nov 9 '12 at 18:54
    
I tried that and the answer was: " ***/.texmf-var/web2c/pdftex/pdflatex.fmt doesn't match pdftex.pool (Fatal format file error; I'm stymied) " –  Lukas Nov 9 '12 at 19:08
    
@user1562373: And the answer for that is a FAQ. –  Martin Schröder Nov 10 '12 at 19:53

2 Answers 2

up vote 3 down vote accepted

There is a question at StackExchange with a error similar to what you get.

The solution stated there was to remove the ~/.texmf-var folder. Usually this folder only has "auto-generated" files, but try this:

mv ~/.textmf-var ~/textmf-var-mackup

and check if the problem goes away. If not, you can rename the backup folder to its original name.

share|improve this answer
    
Thank you very much, it worked! –  Lukas Nov 9 '12 at 20:33
    
Seems very much like a bug in Ubuntu to me. The default TeXLive does not create ~/.texmf-var, but ~/.texlive$YEAR/.texmf-var. –  Martin Schröder Nov 10 '12 at 19:51
    
The problem seems to be related to the system upgrade: Precise and Quantal use different TexLive versions, so when Ubuntu was upgraded the old remaining files "confused" the new TexLive... –  Salem Nov 10 '12 at 21:12

Upgrading has a drawback - programs may not work because of different structures and/or different, new or redundant libraries.

Solution : Try re-installing Kile(or any other program not working).

share|improve this answer
    
Thank you for your answer but I already tried that. The System-Check of Kile found out, that the LaTeX-Binary exists, but doesn't work. Does that give a hint? –  Lukas Nov 9 '12 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.