Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed additional drivers for ATI and Ubuntu Tweak and after some time, I shutdown the laptop and after that, when I tried to turn it on it gives me kernel panic.

I am not able to boot into Recovery Mode. Looks like Ubuntu Tweak did something.

Here is a screenshot of the error I got from recovery console:

enter image description here

share|improve this question

closed as off topic by Jorge Castro, nitstorm, Mik, Ringtail, RolandiXor Nov 12 '12 at 2:10

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to Ask Ubuntu! This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Nov 11 '12 at 15:47

1 Answer 1

Basically you get that error because the kernel can't find the partition specified in GRUB

Cannot open root device "UUID=01CC(...)"

To correct this you shoud edit your GRUB entry during boot. In GRUB menu press E. This will let you edit the selected entry. The text you get should be similar to this:

insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  7919b78e-cb3f-4627-beea-ca78e7e2591c
  search --no-floppy --fs-uuid --set=root 7919b78e-cb3f-4627-beea-ca78e7e2591c
linux   /boot/vmlinuz-3.5.0-18-generic root=UUID=7919b78e-cb3f-4627-beea-ca78e7e2591c ro   quiet splash $vt_handoff
initrd  /boot/initrd.img-3.5.0-18-generic

modify it to become something like this:

insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos1'
linux   /vmlinuz root=/dev/sda1 ro   quiet splash $vt_handoff
initrd  /initrd.img

replacing msdos1 and sda1 with the partition where Ubuntu is installed. Finished the edition, press Ctrl+X. This will hopefully let you start your system. If you still get a kernel panic, then you must be using the wrong partition.

After the system starts, just open a terminal and run sudo update-grub. This should correct all the entries.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.