Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The PC I am working on is in a loud environment. If I need sound, I use the headphone. On my own account this is easy: I mute the speaker in the sound-setting. I am not the only user, others use the Guest-session. And that's what this question about:

Is it possible to turn off the speaker by default on a guest-session AND leave the headphone-output working?

If yes, how can I fix it?

I tried to loosen the speaker (hardware) connection but it is soldered to the mainboard.

The soundcard on the PC is:

HDA Intel at 0xfea78000 irq 44

/proc/asound/pcm ───────────────────────────┐

│00-00: ALC662 rev1 Analog : ALC662 rev1 Analog : playback 1 : capture 1│

│00-02: ALC662 rev1 Analog : ALC662 rev1 Analog : capture 1   

Ubuntu 12.04LTS is running on the system, my account has all the (admin) rights
share|improve this question

1 Answer 1

You need to use alsamixer to accomplish this.

Alsamixer Screenshot

Unfortunately the options you need are not in my screenshot, but if you have headphone sense option (or something similar), unmute that, and if possible, turn the speakers to off. This way, the speakers will be off by default, but the headphones will be enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.