Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a notebook pre-installed with Windows7 and I installed Ubuntu 12.10 on it following the standard installation steps in the installation image.

The only problem is that on reboot the machine continues to boot Windows ignoring the presence of Ubuntu (Grub never comes up).

My partition scheme is this

sda1: NTFS 612MB
sda2: NTFS 50GB (after resizing during Ubuntu installation. This is the main windows partition)
sda4: extended
sda5: ext4 /boot
sda6: btrfs /

I have tried Boot-repair and it didn't help. Tried rEFInd boot manager but it doesn't support NTFS partitions.

I don't know what else to try. My next attempt is to try to install GRUB by hand to the MBR.

Any other Ideas?

share|improve this question
    
Please indicate the URL provided by Boot-Repair. –  LovinBuntu Nov 11 '12 at 19:15

2 Answers 2

If the partition data you presented is accurate, you are not booting in UEFI mode. The computer may support UEFI boots, but most UEFI computers also include a compatibility feature that enables them to boot in BIOS/legacy mode, and my hunch is that's what you're using.

To better diagnose this, I recommend you download the Boot Info Script and run it from a live CD. Post a link to the RESULTS.txt file that the script generates. This information will tell us how GRUB is installed, give us more details about your partitions, etc.

share|improve this answer

I have had the same issue, and a few more... This is how I sorted it out:

I finally sorted it, after understanding a few things and doing:

Installing Ubuntu (you have done that already)

Creating a Live-USB or LIVE-CD (I did it with Universal-USB-Installer)

running Live USB (just restarting your computer for CD, otherwise entering BIOS and selecting usb for booting)

Installing and running boot-repair from Dash Home->terminal with:

Locating boot-repair with this command:

sudo add-apt-repository ppa:yannubuntu/boot-repair  

Updating with:

sudo apt-get update

Installing it with:

sudo apt-get install boot-repair
  • GRUB came out here

Then I logged and couldn't click on anything until I:

Selected Ubuntu Classic/2D in login screen.

  • Here I was able to click on things after

Updating with Software Up to date at the top right hand corner

Restarting and selecting normal mode

Hope it helps, I just fixed it two hours ago!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.