Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed 12.10 from scratch. Unity also started okay, but in a poor resolution. I found a setting (I think it was in "software sources") to change the display driver to Nvidia, and then I rebooted.

When Ubuntu now starts, it goes to the desktop (I see a file that I saved to the desktop) but there are no other screen elements -- no Unity, no menu bar at the top, no window decoration, nothing.

Ctrl-Alt-T and Ctrl-Alt-F2 work as they should, but it's kinda limiting...

  1. How can I restore the default driver? I guess I need a way to open those "software sources" settings again - or anything else that could fix it! I hope I don't have to type all this by hand.
  2. How can I install a proper Nvidia driver so that I can get up to 1280x1024? My old tricks don't seem to work, but perhaps they might if I solve #1...
share|improve this question
    
I had the same problem with ati 5450, which I eventually replaced with Nvidia Gt610 -- and got the same problem. Have just tried everything in this post with no success until ... I did: sudo apt-get remove nvidia-current And rebooted (ie. Without reinstalling nvidia-curent) Now I have unity back –  user116811 Dec 26 '12 at 12:39
add comment

5 Answers 5

up vote 16 down vote accepted

I just went through this myself, the problem is that there is a bug in the Ubuntu installer that removes the Linux Headers needed for the Nvidia drivers to work.

You'll need to do the following:

From a terminal:

sudo apt-get install linux-headers-generic && sudo apt-get remove nvidia-current && sudo apt-get install nvidia-current

If you don't see output from nvidia-current being installed then one of the first two commands failed.

You'll need to reboot, and once you do you'll be able to use your computer again.

share|improve this answer
    
Should I run nvidia-xconfig after the reinstall before I boot normally? –  Torben Gundtofte-Bruun Jan 27 '13 at 20:44
    
This worked for me, thanks! –  Some Random Ubuntu Lover Jul 3 at 18:32
add comment

To restore the default driver you have to uninstall the package nvidia-current. You can do this in your STTYs (Ctrl-Alt-F[1-6]).

sudo apt-get remove nvidia-current

Afterwards simply reboot and you should be fine.

share|improve this answer
1  
The accepted answer did not work for me, complete removing nvidia-current worked. If i tried re-installing it, i would still have the same issue. This answer worked for me. –  prolink007 Dec 30 '12 at 22:26
add comment

The headers I have were newer than the kernel I was running. For that reason I had to upgrade my kernel version. Then, I would recommend the following procedure:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-source
sudo apt-get install linux-headers-generic
sudo apt-get remove nvidia-current
sudo apt-get install nvidia-current
share|improve this answer
add comment

In my case the problem was the proprietary driver from NVIDIA which doesn't work on Optimus laptops. All I had to do was running

sudo nvidia-uninstall

and removing /etc/X11/xorg.conf

OBS: You need to turn off X server to do that. Use ctrl+alt+f1 to go to "interfaceless" mode and type

sudo stop lightdm

After uninstalling run

sudo start lightdm
share|improve this answer
add comment

I had the same issue, nothing helped until I ran this:

sudo apt-get autoremove fglrx --purge
share|improve this answer
    
Just to note, fglrx is for ATI cards –  laconbass Jan 11 at 10:58
add comment

protected by Community Mar 20 '13 at 8:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.