Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My locale setting for LC_TIME is set to Swedish but despite this cal displays Sunday instead of Monday as the first day of the week. Any clues?

$ locale
LANG=sv_SE.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_COLLATE=en_US.UTF-8
LC_MONETARY="sv_SE.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_ALL=

$ grep first_weekday /usr/share/i18n/locales/sv_SE
first_weekday 2

$ cal
   November 2012      
sö må ti on to fr lö  
             1  2  3  
 4  5  6  7  8  9 10  
11 12 13 14 15 16 17  
18 19 20 21 22 23 24  
25 26 27 28 29 30     
share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

cal can not change the start of the week.

You could use ncal which respects those locale settings. If you do not like the layout use ncal -C to switch to the classical cal layout.

share|improve this answer
    
OK, thanks. I didn't know that. –  August Karlstrom Nov 9 '12 at 13:04
2  
Added alias cal="ncal -C" to ~/.bashrc –  August Karlstrom Nov 9 '12 at 13:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.