Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've searched around Ask Ubuntu and the App Developer site, but I can't seem to find the answers to my questions.

I'm wanting to get back into programming, and I'd eventually like get into app development for Ubuntu, but I'm not sure where to get started.

Which version of Ubuntu is currently recommended for app development, especially for those wanting to publish their apps to the Software Centre?

Should app developers use the current LTS release, or, can any of the new releases be used?

Should developers use the 32-bit or 64-bit edition of Ubuntu, or does this not matter?

What effect would the above choices have on the eventual publication of an app?

share|improve this question
add comment

1 Answer 1

Just use the version you want to use yourself. If you stick to LTS stick with it. If you want the newer Ubuntu use that. In general it does not matter what version you use; of course the more difficult your application, the more dependencies, the more you will run into situations where an older Ubuntu does not have a package you require for it to work. But the difference between 12.04 and 12.10 is not that big.

Even if you include packages that are available as of a certain Ubuntu version you need to take care of that in your application yourself, limit the application to a certain Ubuntu version and newer or provide a version that can be used on that version of Ubuntu. It is even possible to create a backport for your application so you can have users get it to use on Hardy (but... most of us would probably not care for that ;) )

If you want it in the official Ubuntu Software Center you are not going to get in into 12.10 and should aim for 13.04 or 13.10. Since you need to follow the official procedure for submitting it. You can skip those steps by creating a PPA.

share|improve this answer
    
+1 Yes! Love this kind of answers. –  jmendeth Nov 9 '12 at 14:26
1  
I would add that you can still get your app into 12.04 or 12.10, either by submitting it through myapps.developer.ubuntu.com/dev or by submitting it to 13.04 and requesting that it be backported to earlier releases. –  mhall119 Nov 11 '12 at 22:51
    
Thanks for your replies. And while they begin to answer the question they don't go far enough. I'm assuming the best practice would be to target the LTS release which should in theory be the most stable. And after a little more digging it seems that when an app is submitted, a binary for both 32-bit and 64-bit is created. So would it be fair to say that I should go with the LTS for stability but using 32-bit or 64-bit would make no difference to the end product? –  EclecticGeekery Nov 13 '12 at 22:27
1  
@wes that has nothing to you with your application. Choice for LTS or latest release is a personal choice for -using- Ubuntu not for coding software. The tools in both are the same and mosttimes even the LIBs are (since the release after a LTS tends to be closely based on the LTS). –  Rinzwind Nov 14 '12 at 7:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.