Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The supported interfaces of the network adapter include also AP. But when I try to set the card on Master Mode with iwconfig wlan0 mode Master, I get the following error:

Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Operation not permitted

Is it still possible with hostapd? I tried to make it run with hostapd, but still no success. Any suggestions? I am trying to do this on Ubuntu 12.04.

share|improve this question
Please use the newer iw over the older iwconfig. Here is a similar issue posted in the Debian Bug tracker for changing ad-hoc mode, but I believe this applies to your master mode case as well: Debian bug #645055 – gertvdijk Jan 21 '13 at 14:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.