Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When connecting any usb stick to my thinkpad ubuntu 10.10 does not recognize them. I don't see anything on the desktop.

the output of "dmesg | tail -n10" gives me:

[ 1965.696388] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1965.884537] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1966.072503] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1966.260349] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1966.506227] usb 1-1: new high speed USB device using ehci_hcd and address 9
[ 1966.572375] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1966.760379] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1966.948358] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1967.136335] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 1967.325423] hub 1-0:1.0: unable to enumerate USB device on port 1

When connecting my usb scanner to the same port:

[ 2008.480135] usb 1-1: new high speed USB device using ehci_hcd and address 65
[ 2008.548389] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2008.736786] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2008.924379] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2009.112348] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2009.300443] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2009.488536] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2009.732180] usb 1-1: new high speed USB device using ehci_hcd and address 71
[ 2014.796299] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 2018.000128] usb 2-1: new full speed USB device using uhci_hcd and address 3

And ubuntu 10.10 recognizes that scanner. So What can i do to see my usb stick? On my other Thinkpad running fedora 14 it works perfectly...

It happens only to storage media (usb sticks, cameras, etc.). My scanner (HP scanjet 2200c) works like a charm.

share|improve this question
    
Post the output of sudo fdisk -l with your USB device plugged in. –  karthick87 Jan 14 '11 at 11:06
    
Platte /dev/sda: 60.0 GByte, 60011642880 Byte 255 Köpfe, 63 Sektoren/Spur, 7296 Zylinder Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x0004c9de Gerät boot. Anfang Ende Blöcke Id System /dev/sda1 * 1 6993 56165376 83 Linux /dev/sda2 6993 7296 2437121 5 Erweiterte /dev/sda5 6993 7296 2437120 82 Linux Swap / Solaris –  user8880 Jan 14 '11 at 14:04
    
@Peter Please add the new information to your question, not a comment, thanks! –  Jorge Castro Jan 14 '11 at 15:09
    
I don't see the relevance of this information to the question... –  jmtd Jan 24 '11 at 15:25
1  
Does this only happen with one USB port, or all of them? Is the Thinkpad running Fedora identical, hardware-wise? Can you try Ubuntu 10.10 on the other Thinkpad (perhaps via livecd), to see if the problem occurs there? Do you have any other USB devices attached? –  jmtd Jan 24 '11 at 15:27

3 Answers 3

I've seen this a couple times lately and it always turns out to be a USB hub or port (hardware) problem. Have you tried different ports and bypassing any hubs?

share|improve this answer

Don't know if any of these ideas will help you, but here I go.... Some options to check (I'd start on points 3 and 5):

  1. Check this question, too: USB Storage Device Automount, and try the solutions proposed there.
  2. Also, you can try palimpsest to check if it's detected and then mount it.
  3. In 10.04 (some people reported it with 10.10, too) there seemed to be a bug that prevented usb automounting. Don't know if that's fixed, but you can try the solution for that case (note that it disables floppy support): sudo modprobe -r floppy (source)
  4. Yet another possibility (quoting this):

    I eventually solved this problem by uninstalling pmount, then re-installing together with libpmount0.0

    Now drives are detected, automount and can be safely removed. No idea what caused the problem on the upgrade, but hope that this helps other people with the same problem.

  5. Here you can find another workaround:

    gksu gedit /etc/modules
    

    Add two lines (at the end of file):

    usb_storage 
    usbhid
    

    (Actually you can check with modprobe -l |grep usbhid and modprobe -l | grep usb_storage if those moduled are already loaded or not before doing the edit.)

share|improve this answer
    
Ooops that link atareao.es/ubuntu/conociendo-ubuntu/ubuntu-lucid-lynx-y-usb is not really english... –  user8880 Feb 1 '11 at 17:01
1  
Sorry... but indeed I took my time to write the solution which is suggested there... in English... for you all... specially you, the asker ;). Anyway, if you need me to translate anything from there for you, just ask... I will be glad to.... and for free :). On the other hand... did any of my suggestions help? –  luri Feb 1 '11 at 18:29

Check your groups. I've had similar problems due to not being in the floppy group.

To see what groups you're in, run:

groups

If you're not in the floppy group, you can add yourself to it by running:

sudo usermod -a -G floppy $USER
share|improve this answer
    
@StephenMyall, I disagree. My suggestion wasn't about improving the question but about eliminating one possible cause of the problem. –  Peter Taylor Aug 21 '12 at 18:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.