Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 12.04 and running it via vmware (probably wont make a difference, no vmtools applied yet). I logged in via ssh and looked at my external HD, the folder was blank. After logging into the start screen a few seconds later my external drive is available.

It appears mount isnt mounting until i login? is there a way to change this? I normally just leave the window in the background and simply use ssh. Extra info: The drive i believe is NTFS

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Yes, normally the automatic mount is done through gvfs, and this does not run until you log in. The reason for that is that otherwise, the system cannot know which user should be given the rights to the mounted disk (remember that NTFS does not allow the Unix permissions and ownership!), and mounting as root would prevent any other user from mounting it.

Depending on what you want to achieve, you have two options.

  1. If this is a disk that is always attached, then make an apropriate entry in /etc/fstab. It will be mounted at boot time.

  2. Use the udev system to create a rule to automount the disk.

  3. Mount manually after you log in with ssh. This can be achieved for example by creating an entry in /etc/fstab with the noauto option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.