Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I download a lot of PDFs in Chromium and always get a warning telling me that "files of this type can harm [my] computer", which forces me to manually confirm every download. I've enabled the "always open files of this type" setting, but that's only useful for after a file has been downloaded. Any way around this warning? Thank you!

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted
  1. Exit chromium
  2. gedit ~/.config/chromium/Default/Preferences
  3. Locate a section that looks like:

    "download": {
      "directory_upgrade": true,
      "extensions_to_open": "",
      "prompt_for_download": false
    },
    
  4. Change the extensions_to_open setting from "" to pdf. If there are already other extensions, use a colon to separate pdf from the existing entries (i.e. foo:bar:pdf).

  5. Save the configuration file.

  • Source
  • Untested; will delete if it is no longer a valid method (it's from 2011).
share|improve this answer
    
Haven't tested this yet, will update once I do. Thank you, very helpful! –  QuietThud Nov 9 '12 at 8:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.