Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am an IT student aide at a college and we have a very small test computer that we started messing around on with 12.04 and used likewise to join it into the Windows network that we have.

However, we are trying to get it to show the "other user" for the manual log on but the lightdm folder with lightdm.conf files are read-only.

How would I be able to change that so I can write to this file?

share|improve this question

2 Answers 2

You need to do this as root as peachy said, but I have a simpler option that you can use besides an editor, you can do this using lightdm-set-defaults.

This will show the "Other" user:

sudo /usr/lib/lightdm/lightdm-set-defaults --show-manual-login true

This will disable the user list, if you just want to see "Other":

sudo /usr/lib/lightdm/lightdm-set-defaults  --hide-users true

And lastly you can turn off guest:

sudo /usr/lib/lightdm/lightdm-set-defaults  --allow-guest false

Doing this you end up with only "Other", or you can just use the first line I posted to add it.

share|improve this answer

You need to open the lightdm.conf as root in order to make changes to it.

Method 1: Via Terminal

  1. Launch the terminal by pressing Ctrl+Alt+T.
  2. Run this command:

    gksu gedit /etc/lightdm/lightdm.conf
    
  3. This will open the lightdm.conf in gedit. Make the necessary modifications you want to the file.

  4. Save and close it.

Method 2: Via Nautilus

  1. Press Alt+F2.
  2. Type gksu nautilus and press Enter.
  3. Type your password.
  4. Nautilus will be launched. You can now browse to File System → etc → lightdm
  5. Open the lightdm.conf and make the necessary modifications you want to the file.
  6. Save and close it.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.