Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Windows XP HDD that no longer wants to mount. Long story short, I tried to acces my data through a Ubuntu Live USB. The hard drive wouldn't auto mount, thus I created a mount point using:

sudo mkdir /media/external

When I try to mount the HDD using

sudo mont /dev/sda2 /media/external -o forcer

I get this error message:

mount: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

How can I force mount my fat16 partition so that I can save my files?

share|improve this question
    
What makes you think it's FAT16, btw? FAT32 was introduced in Windows 95, 6 years before WinXP. –  Sergey Nov 9 '12 at 3:22
    
Gparted says it is Fat16... It's my fathers HDD, I have no idea why he chose fat16. –  Dominic Jordan Hasford Nov 9 '12 at 3:27

1 Answer 1

You need to specify filesystem type explicitly:

sudo mount -t vfat /dev/sda2 /media/external

(you can also try fat, msdos and umsdos). The particular format (FAT32, FAT16 or FAT12) should be detected by the driver automatically, however, you can override it with fat={12|16|32} option.

See man mount for more details on FAT-specific mount options.

share|improve this answer
    
I would replace "-t vfat" by fat, or msdos, or umsdos? –  Dominic Jordan Hasford Nov 9 '12 at 3:32
    
Yes, they're different drivers which share a common core/options: en.wikipedia.org/wiki/FAT_filesystem_and_Linux –  Sergey Nov 9 '12 at 3:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.