Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have bought a Pinnacle PCI TV card:

enter image description here

I also installed Tvtime. I am able to see the multiple channels but there is no sound. After some googling I found this is a standard issue with Tvtime.

So far I tried the following (none worked):

  • running from terminal: tvtime --mixer=hw:0/Line
  • sudo tvtime option --device /dev/video0 | arecord -D hw:1,0 -r 32000 -c 2 -f S16_LE | aplay -

How to make sound to work? You'll get a really cold beer for it :)

share|improve this question
    
Have you tried any other software like kaffeine, vlc, vdr, or even xawtv? –  taneli Nov 14 '12 at 8:36
    
Is it possible to configure the channels without tedious scripting with any of your suggested programs? Or at least having a well written tutorial somewhere. I ussualy spend all my day trying to figure it out and in the end of the day it's still not working. Getting somewhat tired of that. –  Primož Kralj Nov 14 '12 at 10:07
    
If I remember correctly, kaffeine worked "out of the box" about two years ago, the others required more work. I currently have DVB only at work, so can't readily test here at home. –  taneli Nov 14 '12 at 12:35
    
I tried Kaffeine today but it detects no source when going to "Television -> Channels". Under "Television -> Configure Television" there is also no interesting option to set any device or anything. On the other hand I found that my TV card is supported under linux and should work out of the box. –  Primož Kralj Nov 15 '12 at 21:29
    
Ah, too bad. Does your TV card have 3.5mm stereo out? Could you try if that works? Would that be an acceptable solution? –  taneli Nov 16 '12 at 8:59

4 Answers 4

did you try to install XBMC and activate some plugins.... one my friend is solve his problem with

share|improve this answer

Try the trick mentioned in tvtime FAQ#11, that is load (and use) btaudio module and set up sox or similar to pass audio from it to your output device. Assuming /dev/dsp for output and /dev/dsp2 for DVB input:

sox -r 32000 -w -t ossdsp /dev/dsp2 -t ossdsp /dev/dsp

as per their example. Change devices to suit, or if using alsa or pulseaudio.

share|improve this answer

I also encountered the no-sound problem with Pinnacle PCTV (Pro) / TVtime. There is a fairly simple solution not involving tedious scripting:

  • Connect the audio out of the PVTV card to the audio in of the soundcard on the motherboard. NB: Pinnacle PCTV / PCTV Pro does have a physical audio out connector. There should be a connector cable around 25 cm long 3.5 mm jacks stereo male male delivered with the card. If missing, use another regular cable with 3.5 mm jacks stereo male male.
  • I am using Ubuntu 12.04 Precise Pangolin on a mobo with build-in soundcard. Default the line-in connection is disabled, it don't appear in System Settings, Sound. You can enable line-in by installing ALSA Mixer of something like that. You don't have to use it, after installing you can even remove it. Line-in should now appear in the input section of System Settings, Sound.
  • You will have to adjust some volume settings, but it works.

Regards, The Netherlands, Karel de Win

share|improve this answer
  • Connect the audio output from the TV card to the PC line input. In System Settings set the volume of Analog input.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.