Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to set up virtual machines with kvm and spice. Every time I start a virtual machine it outputs an error and runs extremely slow.

max@TuxServer:~$ kvm-spice -hda vdisk.img -cdrom /media/Main/transfer/CDs/ubuntu-12.04-desktop-amd64.iso -boot d -m 1024 -vga cirrus -spice port=5900,addr=192.168.0.1,disable-ticketing
do_spice_init: starting 0.10.0
spice_server_add_interface: SPICE_INTERFACE_MIGRATION
spice_server_add_interface: SPICE_INTERFACE_KEYBOARD
spice_server_add_interface: SPICE_INTERFACE_MOUSE
Could not open option rom 'kvmvapic.bin': No such file or directory
spice_server_add_interface: SPICE_INTERFACE_QXL
red_worker_main: begin
ensure_display_channel_created: create display channel
ensure_cursor_channel_created: create cursor channel

The CPU has AMD-V. The OS is Ubuntu 12.04.1 x64 kernel 3.2.0-29

---------- edit -----------

kvm-ok prints:

INFO: /dev/kvm exists
KVM acceleration can be used

and apt-file search kvmvapic.bin outputs nothing

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Despite not knowing what is the problem, i can give you some tips. First you can check if the problem is caused by that missing file. Using apt-file i get

$ apt-file search kvmvapic.bin
qemu-common: /usr/share/qemu/kvmvapic.bin
seabios: /usr/share/seabios/optionrom/kvmvapic.bin

So you should install qemu-common to get rid of that error.

Also you must check that your computer can run KVM with kvm-ok command:

$ kvm-ok
INFO: /dev/kvm exists
KVM acceleration can be used

As a last advice, despite using kvm-spice should enable by default KVM, you can try passing the flag -enable-kvm. Also you can redirect the logging to a file using -D file.log and try to find some info there.

Hope this helps.

share|improve this answer
    
thanks for the good answer (sorry but I can't upvode) however non of them solve the problem. –  JustMaximumPower Nov 9 '12 at 13:33
    
I guess I was wrong in my comment. Adding -enable-kvm makes the virtual system run at fine speed even thought it still prints the error. So I guess I can ignore the error. –  JustMaximumPower Nov 9 '12 at 13:37
    
did you try installing seabios package? –  green7 Nov 9 '12 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.