Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

10 ubuntu studio and cannot get my ati radeon mobility 4650 to work. from lshw:

*-display UNCLAIMED
            description: VGA compatible controller
            product: M96 [Mobility Radeon HD 4650]
            vendor: Advanced Micro Devices [AMD] nee ATI
            physical id: 0
            bus info: pci@0000:01:00.0
            version: 00
            width: 32 bits
            clock: 33MHz
            capabilities: pm pciexpress msi vga_controller bus_master cap_list
            configuration: latency=0

from lspci:

 00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)

from lsmod:

Module                  Size  Used by
vesafb                 13797  1 
ip6t_REJECT            12574  1  
xt_hl                  12521  6 
ip6t_rt                12558  3 
nf_conntrack_ipv6      14054  7 
nf_defrag_ipv6         13158  1 nf_conntrack_ipv6
ipt_REJECT             12541  1 
xt_LOG                 17349  10 
bnep                   18140  2 
xt_limit               12711  13 
xt_tcpudp              12603  18 
rfcomm                 42523  0 
bluetooth             209256  10 bnep,rfcomm
xt_addrtype            12635  4 
parport_pc             32688  0 
ppdev                  17073  0 
uvcvideo               76749  0 
xt_state               12578  14 
videobuf2_core         32851  1 uvcvideo
videodev              120309  2 uvcvideo,videobuf2_core
videobuf2_vmalloc      12860  1 uvcvideo
videobuf2_memops       13368  1 videobuf2_vmalloc
ip6table_filter        12815  1 
ip6_tables             27207  2 ip6t_rt,ip6table_filter
nf_conntrack_netbios_ns    12665  0 
joydev                 17457  0 
snd_hda_codec_hdmi     32007  1 
nf_conntrack_broadcast    12589  1 nf_conntrack_netbios_ns
snd_hda_codec_realtek    77876  1 
nf_nat_ftp             12649  0 
nf_nat                 25254  1 nf_nat_ftp
nf_conntrack_ipv4      14480  9 nf_nat
nf_defrag_ipv4         12729  1 nf_conntrack_ipv4
snd_hda_intel          33491  7 
snd_hda_codec         134212  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
nf_conntrack_ftp       13359  1 nf_nat_ftp
arc4                   12529  2 
snd_hwdep              13602  1 snd_hda_codec
nf_conntrack           82633  8 nf_conntrack_ipv6,xt_state,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_nat_ftp,nf_nat,nf_conntrack_ipv4,nf_conntrack_ftp
iptable_filter         12810  1 
snd_pcm                96580  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
ip_tables              26995  1 iptable_filter
coretemp               13400  0 
snd_seq_midi           13324  0 
snd_rawmidi            30512  1 snd_seq_midi
iwlwifi               390922  0 
snd_seq_midi_event     14899  1 snd_seq_midi
lp                     17759  0 
kvm_intel             136907  0 
snd_seq                61521  2 snd_seq_midi,snd_seq_midi_event
psmouse                95552  0 
parport                46345  3 parport_pc,ppdev,lp
x_tables               29711  13 ip6t_REJECT,xt_hl,ip6t_rt,ipt_REJECT,xt_LOG,xt_limit,xt_tcpudp,xt_addrtype,xt_state,ip6table_filter,ip6_tables,iptable_filter,ip_tables
samsung_laptop         14532  0 
snd_timer              29425  2 snd_pcm,snd_seq
snd_seq_device         14497  3 snd_seq_midi,snd_rawmidi,snd_seq
serio_raw              13215  0 
mac_hid                13205  0 
lpc_ich                17061  0 
video                  19335  1 samsung_laptop
kvm                   418206  1 kvm_intel
snd                    74638  24 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
mac80211              544104  1 iwlwifi
soundcore              15047  1 snd
snd_page_alloc         18484  2 snd_hda_intel,snd_pcm
microcode              22803  0 
cfg80211              202470  2 iwlwifi,mac80211
binfmt_misc            17500  1 
sky2                   58111  0 

Can anyone help? I have tried installing the driver from ati but when I run the aticonfig --intial I get the following:

aticonfig: No supported adapters detected

The graphic modes were fine when I first installed but I tried to install the fglrx module and it all went pear shaped. I suspect that if I delete xorg.conf it will go back to normal but I want to have the ati command center.

Thanks,

J.

share|improve this question
    
See the 2nd answer to this question, it will explain askubuntu.com/questions/124292/… –  Stephen Myall Nov 8 '12 at 19:00

2 Answers 2

See if this page helps you any:

https://help.ubuntu.com/community/BinaryDriverHowto/ATI

share|improve this answer

If you are using 12.10 you should take a look at this thread which describes a similar problem and the solution offered in this other thread.

The solution above worked for me and is as follows;

"For those who have hybrid systems (ATI/intel) and fglrx has stopped working in 12.10, then the problem might be like the one described here (fglrx incompatibility with the recent version of the intel driver): https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1068404

What I would suggest would be

Remove all the fglrx* packages:

sudo apt-get purge fglrx*

Add my PPA in your repositories list:

sudo add-apt-repository ppa:andrikos

Update your package information:

sudo apt-get update

Update the fglrx and intel drivers:

sudo apt-get install fglrx xserver-xorg-video-intel

Don't forget to enable the fglrx driver

sudo aticonfig --initial --force"

Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.