Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Installing Ubuntu on a Pre-Installed UEFI Supported Windows 8 system

I recently purchased a new HP computer (P6-2330) with Windows 8. I have tried unsuccessfully to install Ubuntu 12.10 64bit alongside Windows 8. The computer is UEFI with Secure Boot enabled. I've tried following the instruction at https://help.ubuntu.com/community/UEFI.

I am able to get the GRUB menu to show up. However, as soon as I press Enter on either Try Ubuntu or Install Ubuntu, the screen goes blank. Nothing works at all, not even the Num Lock or Caps Lock keys on the keyboard. I have to use the power button to restart the computer. Does anyone have any suggestions on how to get Ubuntu installed?

To clarify, I have actually tried installing using both a USB stick and a DVD. The USB stick gave a blank screen, while the DVD gave the error message "Empty Security Header" after pressing Enter at the GRUB screen.

share|improve this question

marked as duplicate by Luis Alvarado, Jorge Castro, Takkat, Ringtail, Eric Carvalho Jan 4 '13 at 0:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Have you tried to disable the Secure Boot in the BIOS ? –  LovinBuntu Nov 9 '12 at 12:20
    
Oh yeah. The Ubuntu DVD/USB stick won't boot past GRUB at all unless it's in what my UEFI Configuration program calls "Legacy" mode! –  rft183 Nov 9 '12 at 15:03
    
Your problem may not be due to SecureBoot, but to graphical problems. Please tell me if you can access the Advanced Welcome Page. If yes, please try to add the nomodeset option as explained here. –  LovinBuntu Nov 13 '12 at 11:33
    
I ended up reinstalling Windows 8 in BIOS mode so that I could install Ubuntu in BIOS mode as well. My understanding was that in UEFI mode, Ubuntu went straight to text grub rather than Advanced Welcome Page. Mine did, anyway. I did try the nomodeset option, which didn't help. I can't really try anything else now though, since I've got everything working in BIOS mode. Thank you for trying to help! –  rft183 Nov 15 '12 at 22:13

3 Answers 3

I'm not thrilled with this solution, but it has worked. I paid an extra Microsoft tax of $40 to upgrade my Windows 8 to Windows 8... Then I reconfigured my UEFI settings so that I could do everything in BIOS mode. I reformatted my hard drive using gparted so that it was in msdos style instead of gpt. I then clean installed Windows 8. Since it was an upgrade disk, I had to "upgrade" the freshly installed Windows 8 with Windows 8. I was then able to install Ubuntu. Ugh. I hope this mess is straightened out soon.

share|improve this answer

@ Athelstan - this is the solution that many other threads were missing. Unfortunately, I found this thread after a few hours of tweaking it on my own :)...

Allowing for legacy USB and reordering the boot order was not enough to install 12.04 cleanly. Many people have been reporting the "missing file" error or the inability to get past the black screens. At one point, I could chose the boot disk, but it wouldn't allow it.

Moral of the Story: Win8 is a beast and the hardware setting reflect this. Setting "Secure Boot Control" to DISABLED and tweaking the UEFI settings allowed for me to seamlessly install 12.04 on a new laptop with Win8.

B

share|improve this answer

I found in my bios a setting called "Secure Boot Control". I set it to disabled and now can boot into Ubuntu and Windows 8 with no issues.

share|improve this answer
1  
I tried pretty much every setting there was in bios (there aren't that many on my computer btw...) including disabling Secure Boot. Still didn't help. I did get Ubuntu and Windows installed though, as you can see from my "answer." –  rft183 Nov 15 '12 at 22:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.