Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything was working perfectly fine on my ubuntu machine since I installed it almost a week ago... until this morning. My computer has been running slow all day, particularly the dash (and I mean really slow). I went to the system settings with the idea of changing my graphics driver to the proprietary one to see it it would fix the problem. Surprise! Ubuntu doesn't detect my graphic card anymore.enter image description here

I remember there being three options here (at least one proprietary driver and one open source driver). Is there a (safe) way I can force Ubuntu to re-check the hardware without re-installing the whole system?

If it changes anything, the graphics card was from ATI (I don't remember the model, but I could boot my "legacy OS" to check if need be).

Thanks for your help, - Calixte

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Check this thread: Can't install ATI proprietary drivers in 12.10

From the begging Ubuntu (version 12.10) didn't recognized my graphics card. The solution for me was:

sudo apt-get purge fglrx*
sudo apt-get install fglrx
sudo aticonfig --initial

After reboot my desktop was OK and I did the next check:

sebastian@linux:~$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6700 Series  
OpenGL version string: 4.2.11903 Compatibility Profile Context

Now the driver recognizes my graphics cards. On the System Details now I see as Graphics VESA :00. Apparently everything is working fine now.

share|improve this answer
    
Worked, thanks. It doesn't give me the option to switch to the proprietary driver anymore, but as long as it works I'm happy. –  Calixte Nov 9 '12 at 8:37
add comment

https://help.ubuntu.com/community/i810

add -k... should give you the grapic drivers too. I hope this is right :/ couldnt find something else...

edit: It should give you the current version... so at least you can look if you're up-to-date or not.

share|improve this answer
    
i810 is an old Intel driver. What does it have to do with ATI cards? –  mikewhatever Nov 8 '12 at 17:57
    
I posted it, because of the command given in this link –  Seemax Nov 8 '12 at 18:50
    
Didn't have time to try it out as the answer above worked. Thanks anyway :) –  Calixte Nov 9 '12 at 8:38
    
as lonf as your Hardware is working again, I guess its fine :D –  Seemax Nov 11 '12 at 12:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.