Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Asus 1225N and I've installed Ubuntu 12.10 but I have 2 major problems:

  1. Sometimes when I restart the system after boot my touchpad and keyboard don't work and I must reset 3 or 4 times

  2. When the system boot nothing, shows only purple screen without Ubuntu logo and sometimes stucks at this page and I must reboot the system 2 or 3 times.

I didn't find menu.lst in /boot/grub. Is this problem occurred for missing menu.lst?

Thanks for helping.

share|improve this question

No, it's not because of that. Ubuntu 12.10 uses GRUB2, which according to this wiki, doesn't use menu.lst anymore.

As for your touchpad problem, have a look at this question.

share|improve this answer

I'm not sure if you should mix up many questions into one. If people search for questions by different criteria they might not find yours.

Anyway, I can only say something definite about the menu.lst issue. Ubuntu switched a while ago to the Grub2 bootloader (from legacy grub). There is a new and very different configuration mechanism, no more menu.lst. For details see here:

I'm not sure about your other problems, they might be hardware compatibility issues. You should be able to find more information in the System log in /var/log/syslog Although it is not so easy to interpret this information, depending on you experience with Linux.

share|improve this answer

I had an Asus 1225B and had the same touchpad/keybpoard unresponsive problem on 12.04 but was able to fix it. Take a look at this Launchpad Bug comment (bug is #1014240). It is a kernel related issue, and can be fixed by booting with a different/non-default boot option by changing grub's defaults.

  • Basically, you need to edit (as root) /etc/default/grub by adding the following options to the variable GRUB_CMDLINE_LINUX_DEFAULT: "i8042.reset i8042.nomux"
  • By default, the file should already have GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  • So basically you'll change that line to say:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset i8042.nomux"

  • Save the file.

Don't forget to execue sudo update-grub after. Reboot to test.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.