Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have previously installed the 'gnome-session-fallback' package to get the standard Gnome desktop instead of unity. I normally just select 'Gnome Classic' when I log in. Just now, I logged in with unity instead just to test it, and now I can't get back to Gnome.

If i select 'Gnome Classic' on the login screen, I get unity instead. 'Gnome Classic (No effects) does launch Gnome instead of unity, but I want the real thing.

How can I have my Gnome desktop back?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

This is not exactly as you said. I had this problem in the past. Gnome-classic loads the gnome-classic environment with effects. Sometimes is not disable the Unity plugin (it should do) and you have a gnome-classic environment with Unity Launcher.

Try 2 things.

First try to re-install gnome-classic environment with this command

sudo apt-get install --reinstall gnome-panel

OR

Install the compizconfig-settings-manager with this command

sudo apt-get install compizconfig-settings-manager

Open it via terminal with this command (or you can call it from Dash)

ccsm

and disable manually the Unity Plugin. (but this is just a workaround)

share|improve this answer
    
I already use CCSM, so disabling the Unity Plugin was very quick and easy. Thanks for providing such a simple solution! –  Kalle Elmér Nov 8 '12 at 15:22
    
In at least 12.04 and newer, "Gnome Classic" should be loading GNOME shell, which does not use compiz, nor gnome-panel. –  dobey Nov 8 '12 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.