Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu 12.10 and No Machine NX Server (3) etc. I've gone home, and have discovered that the windows nx client (3.5) will not display fonts for graphical applications.

The same client works fine connecting to Ubuntu 12.04

How can I fix this issue?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Thanks joeforker - the magic setting on the "Use Custom Settings" panel was to check the "Disable the render extension"

share|improve this answer

I was able to get the fonts to show up in GTK applications by going into the NX client's "Use custom settings" panel and checking "Disable..." for all the "Performance" checkboxes. Qt applications work fine either way.

share|improve this answer
    
Watch out doing these changes : it seems that suspended sessions are no more available when changing such settings. So plan to close current sessions and restart new ones . –  user286886 May 30 at 15:22

I had the exact same problem. Changing the client to OpenNX:s client solved the problem for me. I've been running it for a couple of days now and it works like a charm. http://opennx.net/

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Ringtail Nov 23 '12 at 1:15
    
Not working for me - at the moment I'm using putty and Xming to get around the issue - Xming starts up when I try OpenNX. Also, I prefer not having a desktop, and OpenNX does not seem to support the "custom" unix view. –  Stephen Nov 24 '12 at 10:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.