Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 on a Dell latitude E6410, I have a problem when using the VGA output I always have dual monitor and can't switch on the "mirror display" toggle under systems setting/displays. It's rather annoying when having to do presentation with a video projector. the option "mirror display" is in light grey and I can"t tick the box.

Thanks for those who might have an idea how to resolve this?

update: driver is: Intel® Ironlake Mobile x86/MMX/SSE2

card something like this ? description: VGA compatible controller product: Core Processor Integrated Graphics Controller vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 02 width: 64 bits clock: 33MHz

share|improve this question
    
can you edit your answer ;) –  Nemo Peeters Nov 14 '12 at 5:46
    
Who are you asking to edit an answer? There isn't an answer here. –  hexafraction Nov 14 '12 at 13:32
    
Hi,Jorge castro asked me to specify the driver and video card, I was just hoping he (or someone else, maybe you) could then come up with a clever idea as to why I can't switch on the "mirror display" in my display control. Thanks for your time –  Nemo Peeters Nov 16 '12 at 11:31
    
I really don't know much about Intel cards. I'll add a bounty to draw attention, though. Don't know how much it'll help/ –  hexafraction Nov 16 '12 at 12:19
add comment

2 Answers

It's possible (though i'd see it as rather improbable) that your displays have no unified resolution, as in, there is no resolution the system can set and display on both at once.

Usually, though, there are several "fallback" resolutions, such as 1024 x 768. While most displays are superior to this now, they will still work at this resoltuion if told to.

Check your options for each screen resolutions, and see if there are any matching.

It's possible setting it manually may help, although both of mine allowed me to tick the box and then automatically limited my resolution options (which is also stated below the checkbox).

share|improve this answer
add comment

I think this is a design problem: for many laptops, only one screen resolution is listed by the display setting tool and xrandr, even though the hardware is capable of other suboptimal modes (resolutions). The current laptop I am using and for which I am experiencing this problem is a Samsung serie 9 NP900X3C running Ubuntu 12.04 with an Intel® HD Graphics 3000 and an optimal resolution of 1600x900 pixels (that usually is not supported by projectors).

I solved this in the following (not very practical) way:

1) connect the projector. This makes all the projector resolutions available, although not directly usable by the laptop screen

2) issue the following command, possibly testing several resolutions from the projector

xrandr --addmode <laptop_monitor_name> <projector_compatible_resolution>

note that this command fails before I connect the projector, it seems that xrandr becomes aware of them only with the projector connected.

3) use either xrandr or the normal display settings to select the common resolution and mirror the displays.

This has been working for me, but it would be much better if there was a function in the display settings that did this automatically, or at least in a more intuitive way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.