Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with Intel HD and Nvidia GPU video cards and I have a problem with installing drivers for the second. They mess everything up. Unity don't want to start, because GLX MISSING ON DISPLAY 0:0 and resolution of screen is 640x480, though, I can't change it in terminal.

xrandr -s 1920x1080

says this kind of mode doesn't exist.

I looked up this problem and it's due to Nvidia drivers (I tried to install 310.14, but it doesn't work with other versions neither), so I want Ubuntu to see only my Nvidia card and forget about Intel one.

How do I do it?

share|improve this question
    
I have a similar problem which sounds exactly like yours. However, I use Lubuntu 12.10 and also tried installing the drivers through Nvidias script (sudo sh NVIDIA-Linux-x86-304.64.run). When I run nvidia-settings it complains that I'm not using the NVIDIA X driver and asks me to run nvidia-xconfig as root to create /etc/X11/xorg.conf, which it does, but it doesn't help. –  ralphtheninja Nov 9 '12 at 15:25
add comment

1 Answer 1

An article in Ubuntu Community Help covers the subject of Hybrid Graphics.

I will outline the main things:

First you've to determine if your kernel has been compiled with the proper option. When it has this option you can use this option to activate a GPU. You can do this by terminal and with a GUI. The script for this GUI has been provided in the article.

Note that this method is not supported by all machines and only works if you are using the opensource driver (nouveau, radeon) and not the proprietary ones (nvidia, fglrx).

share|improve this answer
    
Okay, but I am using a proprietary drivers, as I said above, it's 310.14 from nvidia's site. How do I turn off or delete drivers for intel hd graphics and turn descrete gpu? –  Andrew Nov 8 '12 at 22:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.