Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After running GSmartControl, I received three checksum errors on my storage hard disk.

Error in Attribute Data structure: checksum error

Error in Attribute Thresholds structure: checksum error

Error in ATA Error Log structure: checksum error

Does this indicate a hard disk failure?

Because, this is the THIRD TIME I have replaced the same hard disk. (after seeing this error)

The hard disk is a Western Digital Caviar Green. (2 TB)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It indicates that either the drive is returning bad SMART information, or GSmartControl is broken and doesn't understand it. Try the disk utility that comes with Ubuntu and see if it can read the SMART data. My suspicion is that GSmartControl is broken since I also have a WD Caviar Green ( 1.5 TB ) and it works fine.

share|improve this answer
    
Hmm interesting...When running smartctl from the command line, I received "No Errors Logged" ---- So it would appear that your theory was correct and the GUI was the problem... Is there any other way to check this? –  Ademos Jan 30 '11 at 16:59
    
Yes, as I said before, run the disk utility that comes with Ubuntu. –  psusi Jan 31 '11 at 14:14
    
Thanks for the response --- I'm running Kubuntu not Ubuntu, but if you can give me the official name of the software you're thinking of, I can try it and report back. –  Ademos Feb 6 '11 at 1:58
    
@Ademos it calls itself just "Disk Utility" and comes in the gnome-disk-utility package. –  psusi Feb 6 '11 at 16:21
    
Thanks! --- After installing "gnome-disk-utility" on Kubuntu, I was able to learn that my hard disks are INDEED healthy. –  Ademos Feb 18 '11 at 5:22

No, I don't believe this indicates a bad hard drive. I think these errors indicate that either SMART isn't switched on in your bios or that the hard drives don't really have that capability. My guess is that they're reading in random bytes or zeros.

share|improve this answer
    
Well after running smartctl from the command line, the software told me that SMART was available AND turned on. ---- smartctl also reported no errors... As I asked below, is there any other way to check this? Or does this mean all is well? –  Ademos Jan 30 '11 at 17:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.