Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to listen to music on my home server from work. Both are Ubuntu boxes running pulseaudio. It seems from researching that applications communicate to the PA server via TCP on port 4317, so I figured it should be as easy as:

me@work: ssh -YR 4317:localhost:4317 me@home

At this point I can run rhythmbox from the ssh session with X11 forwarding, and I assumed rhythmbox would be transparently talking to pulseaudio over the reverse tunnel, resulting in the music playing on my work machine. However instead it appears that the music still plays on my home computer. I've tried messing around with PULSE_SERVER as well to no avail.

Has anyone accomplished something similar? It seems like this should be relatively simple due to pulseaudio's design. I've played around with mounting my music library via sshfs instead but I'd really like to have one set of metadata/app settings/playlists and such. Thanks for any tips!

share|improve this question
    
sounds like rhythmbox either isn't configured to play via pulseaudio (from what I know it goes via gstreamer so I'm not really sure where this config setting would be), or its connecting to a local pulseaudio server rather than your tunnel (if pulseaudio is already running on 'home', then have you checked your port redirection is even getting set up properly?) –  drfrogsplat Aug 13 '10 at 7:59
    
I have no answer but paman might be able to help you. It's a configuration tool for pulseaudio. Theoretically on the side with rhythmbox you should change the stream to go through the network (with the help of device chooser or pavucontrol) and I have no idea what to do on receiving end. –  vava Aug 13 '10 at 8:01
    
This sounds like an awesome idea, but won't the bandwidth requirements be too high for most people's home broadband to cope? –  Matt Aug 13 '10 at 9:12
    
Have you checked all of the issues mentioned here: pulseaudio.org/wiki/FAQ#HowdoIusePulseAudiooverthenetwork –  moberley Aug 13 '10 at 10:13
    
Have you enabled networked PulseAudio in paprefs? –  maco Aug 13 '10 at 15:48
show 1 more comment

1 Answer

up vote 4 down vote accepted

I never tried personally, but take a read on this:

http://razor.occams.info/blog/2009/02/11/pulseaudio-sound-forwarding-across-a-network/

Also check the comments, there is one describing an improvement.

share|improve this answer
    
Thanks, this looks promising. I found it earlier but was looking for something more zero-conf, but I will give it a go this week when I'm back at that computer and report back! –  mrooney Aug 15 '10 at 7:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.