Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After by battery died on my laptop I started my computer after plugging it to the ac adapter, for no reason that I know I cant use the visual effects any more as if my graphic card is not installed (my graphic card is GeForce 300m and nvidia x-settings is working)

I tried generating a new xorg.conf file but nothing happened I marked all the installed nvidia driver in synaptic for re installation and didn't really help

I googled the problem appears to be popular but couldn't find a solid solution

Any Ideas ?

share|improve this question

2 Answers 2

Have you tried to re-install drivers (which I assume proprietary ones, as you talked about nvidia-settings)? Are you getting the right resolution or low-res mode?

share|improve this answer
up vote 0 down vote accepted

Thanks luri for the help but I figured it out

What I did is this:

Downloaded the nvidia driver from their website

reboot -> recovery mode -> root command line level -> uninstall all nvidia drivers -> get down to level 3 "telinit 3" -> stop gdm "service gdm stop" -> delete xorg.conf file -> install nvidia that I downloaded

Everything is now perfect

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.