Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had installed Java

ii  icedtea-6-jre-cacao                           6b24-1.11.5-0ubuntu1~12.04.1                    Alternative JVM for OpenJDK, using Cacao
ii  icedtea-6-jre-jamvm                           6b24-1.11.5-0ubuntu1~12.04.1                    Alternative JVM for OpenJDK, using JamVM
ii  openjdk-6-jre-headless                        6b24-1.11.5-0ubuntu1~12.04.1                    OpenJDK Java runtime, using Hotspot JIT (headless)
ii  openjdk-6-jre-lib                             6b24-1.11.5-0ubuntu1~12.04.1                    OpenJDK Java runtime (architecture 

and had installed addon in Firefox browser QuickJava 1.8.0.

And still keep getting message Javascript enabled, but Java is not enabled in Firefox browser while trying to use on-line bill payment facility.

share|improve this question

2 Answers 2

It looks like you don't have the required browser plugin installed.

The following commands will install version 7 instead of version 6 because it is more secure. If version 6 is required, just substitute the command accordingly.

First,

open a terminal and typing the following commands:

sudo apt-get update
sudo apt-get install icedtea-plugin icedtea-7-plugin 

After installation,

restart firefox, click on "Add-ons", select "Plugins", and set the plugin to "Always Activate" (I believe you must enable the plugin here first, so that it may be available to the "quickjava" extension).


Also, webupd8.org maintains security updates for an Oracle Java installer ppa. The newest version is version 8 but versions 6 and 7 are also available. This package includes the non-opensource Oracle version of Java JDK, JRE, and the browser plugin as well. Type the following commands in an open terminal to install this package:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

You may change the last command from version 8 to install version 6 or 7 accordingly.

See here for more info: install-oracle-java-8-in-ubuntu-via-ppa

Also, for security purposes, it best use "quickjava" to disable the java plugin when it is not in use.

share|improve this answer
    
On a side note: this is an NPAPI plugin so it won't work with google-chrome, chromium, and certain versions of opera. However, this plugin should be fully supported by firefox. –  mchid Aug 25 at 15:13

Open firefox ,Type about:config in address bar. Click on I'll be careful,I promise

Find javascript.enabled option. . Change it to true.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.