Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use dual display with Ubuntu 12.04.

Display 1: Thinkpad T420s. Intel HD3000
Display 2: HP 1955.

Whenever I want to maximize the windows (say a Chrome browser) in display 1, it automatically goes to display 2.

I tried several ways to maximize a windows (shortcut, maximize button, mouse drag-to-top) and it's resulting the same.

Any idea how to resolve this?

share|improve this question
    
duplicate of askubuntu.com/questions/52716/… ? –  medigeek Nov 8 '12 at 6:24
    
Do you experience this problem with other programs, not just Chrome? –  Flimm Jan 18 '13 at 17:59

2 Answers 2

The comment to the other answer is the best solution:

"It apparently a bug of Google chrome on ubuntu 12.04, workround: instead of maximizing Google chrome by maximize button or drag-to-top on display 1, do the followings: 1. ctrl+super+left 2. ctrl+super+up –"

So to maximize Google Chrome, press Ctrl+Win+LeftArrow then Ctrl+Win+UpArrow

share|improve this answer

Install ccsm (compizconfig-settings-manager) and enable the "place windows" plugin. You can force a window to be placed at specific pixel top/left.

There's also General options > Display settings. You can add your monitors' width x height and/or set Overlapping Output Handler to prefer screen with mouse pointer.

share|improve this answer
    
couldn't figure it out with your suggestion. However, it only affected Google chrome but works perfectly with the rest (Chromium, Nautilus, Document viewer) –  Husni Nov 8 '12 at 10:35
4  
It apparently a bug of Google chrome on ubuntu 12.04, workround: instead of maximizing Google chrome by maximize button or drag-to-top on display 1, do the followings: 1. ctrl+super+left 2. ctrl+super+up –  Husni Nov 8 '12 at 10:40
    
@Husni Huge thanks for the last one. After I used it one time the bug was gone. It was happening in chromium and firefox –  Jarco Nov 23 '12 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.