Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 12.10 64 bit and a Nvidia card GT430 and installed 304.60 Linux driver manually and it worked beautifully until the latest Ubuntu update which got modified to 3.5.0-18 Kernel. Everything has gone: launcher, windows I can't move them it got USELESS. I tried to run the previous kermel 3.5.0-17 with which the driver was working well. I gto the same desktop. USeless - So the problem is something else I guess but it has to do with the update that's for sure- Any idea what to do? Now I have to switch back to Windows 7 which I don't want in order to able to work until an update will come up.

share|improve this question
Every manually installed driver must be rebuilt against each new kernel. Simply boot in recovery mode and re-run the Nvidia driver installer. – mikewhatever Nov 8 '12 at 5:59
@mikewhatever - How does one do that? I'm similarly afflicted, but have no idea what commands to run. – Konklone Nov 8 '12 at 15:20
But what if the driver is not compatible with the Kernel? – Janos Fejos Nov 8 '12 at 15:54
@Konklone Run the same command you've used to install it, just from the recovery mode, in other words sh – mikewhatever Nov 8 '12 at 16:01
@JanosFejos Nvidia drivers usually have very good kernel compatibility. What makes you think it's incompatible with 3.5.0-18? Have you tried rebuilding yet? – mikewhatever Nov 8 '12 at 16:04

I was able to solve this by following rft183's approach here:

Desktop does not show when I installed nvidia drivers!

Basically, install the linux-source and linux-headers-generic packages, then reinstall the nvidia-current-updates package (it worked for me just by providing the --reinstall flag, I didn't need to remove the package). Then reboot.

share|improve this answer
Well it seems it got fixed But I'm not sure how. I followed the steps what @Konklone posted than I downloaded and reinstalled the latest Nvidia driver manually. I rebooted. It didn't get fixed right away than I thought: It has to do with Compiz and Unity too because both got crashed. So than I'm guessing I reset both Unity and Compiz but here is the thing: I don't really remember which command line was the curing pill. Unity --reset or Unity --replace ( --reset got deprecated) or Compiz --replace I don't know how but it got fixed for now. – Janos Fejos Nov 9 '12 at 2:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.