Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install new nvidia drivers R310 so I downloaded driver and when I run it it says that i can't install new drivers because there is this nouveau driver. It asked me if I want to add blacklist file with nouveau in modprobe so I said yes please. After reboot same thing, I searched through endless topics/questions/etc, i ran sudo apt-get remove --purge xserver-xorg-video-nouveau and tried other things and still didn't find solution how to install new drivers.

share|improve this question
add comment

3 Answers 3

BinaryDriverHowto/Nvidia says it is unnecessary to remove the Nouveau drivers.

Instead of downloading R310 directly yourself, try doing it through Ubuntu's "Additional Drivers" feature. Follow the instructions at Steam Support > Home > Steam > Troubleshoot and How-To's > Linux Issues > Switching Proprietary Drivers, which I'll copy here for convenience.

For Step 2, select "NVIDIA accelerated graphics driver (*experimental*beta) (version experimental-310)". Note that "Additional Drivers" has an incorrect URL for version 310. The correct URL is here.

I tried the following directions, and I am not prompted to remove the Nouveau driver.

To change to the recommended proprietary driver used by Ubuntu, do the following:

  1. Open Additional Drivers either through Systems Settings or by clicking the Unity dash icon and entering "additional drivers".
  2. From the list of available drivers, select the proprietary driver requested by Steam. Your current driver is indicated by a green symbol. If the recommended driver is not listed, you will need to update your package cache by clicking the Update button.
  3. Click the Activate button.
  4. Click the Close button.
share|improve this answer
    
How does one do this from the command line? I'm in a state where I have no Unity and no chrome on windows, just a barebones Gnome environment (fortunately my global keyboard shortcuts to open terminals work). –  Konklone Nov 8 '12 at 15:23
    
@Konklone : You need to run ` sudo apt-get --purge remove nvidia*` followed by sudo apt-get install nvidia-current. Looks like you found a similar solution on your own. –  Stefan Lasiewski Nov 11 '12 at 5:39
add comment

I was able to solve this by following rft183's approach here:

source

Basically, install the linux-source and linux-headers-generic packages, then reinstall the nvidia-current-updates package (it worked for me just by providing the --reinstall flag, I didn't need to remove the package). Then reboot.

share|improve this answer
add comment

This will not work with older NVIDIA GPUs. I have a GeForce 5500 and the only fix was to install a legacy driver from the NVIDIA website.

I discovered this after looking at the syslog (log file viewer --> syslog) file which pointed me to the http://www.nvidia.com/object/unix.html site. The message will also tell you which NVIDIA driver you should download (in my case version 172.14.xx).

When you download the file you'll need to set it as an executable.

Open folder, right click file --> properties --> permissions --> Check Execute -->close.

Next you need to run it as administrator from outside your current x-session. Press CTRL-ALT-F1.

change the current directory (cd/) to the folder where the file is located and run:

sudo ./[Name of the driver goes here]

Then answer all the yes/no questions (mine had a couple of errors which I continued through) and it should work.

Best of luck,

Gil

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.