Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to use the terminal to open a folder with a Japanese title. If I use - ls to see the name of the folder, all it shows is: " ■ ■ ■ ■ " . The actual title is: " 源氏物語 ".

What should I do? Thanks in advance.

share|improve this question
add comment

1 Answer 1

It could be the Ubuntu Mono font not supporting Japanese characters. Try installing the Advanced Settings tool, and changing the Monospace font to something that supports Japanese characters.

share|improve this answer
    
Thanks. How can I do this, using just the Terminal? –  Alfamirto Nov 7 '12 at 22:30
    
sudo apt-get install gnome-tweak-tool You can then open the tool, and go the the Fonts Panel, where you should see an entry for "Monospace Font", which you can select from all the fonts installed on your system. The program can be run by typing gnome-tweak-tool in the terminal. –  kelvinsong Nov 7 '12 at 22:33
1  
You don't need gnome-tweak-tool. You can change the font in the terminal itself by going to Edit->Profile Preferences. –  dobey Nov 7 '12 at 23:01
    
Also, it could be the filename being encoded in a different character set. Changing the font wouldn't necessarily help in that case. The folder could be renamed to the correct set of characters in UTF-8 instead, and it would just work. –  dobey Nov 7 '12 at 23:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.