Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have already :

  • Installed the server
  • Generated the pub/pri keys with -P ""
  • Copied the id_rsa.pub to authorized_keys
  • ssh localhost > answered "yes", copied to known_hosts
  • tried ssh localhost >> still asks for password

Output:

hduser@hduser1-desktop:~$ ssh -v localhost
OpenSSH_5.3p1 Debian-3ubuntu7, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /home/hduser/.ssh/identity type -1
debug1: identity file /home/hduser/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/hduser/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-
3ubuntu7
debug1: match: OpenSSH_5.3p1 Debian-3ubuntu7 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu7
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /home/hduser/.ssh/known_hosts:3
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering public key: /home/hduser/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/hduser/.ssh/identity
debug1: Trying private key: /home/hduser/.ssh/id_dsa
debug1: Next authentication method: password

Any suggestions ?

Cheers

share|improve this question

1 Answer 1

Try using ssh-copy-id. You may have permission issues. This program it sets the proper permissions

share|improve this answer
    
its localhost so shouldn't it resolve such issues ? –  user1435470 Nov 7 '12 at 21:00
    
Issue resolved: chmod g-w homedirectory . This is a weird prob or bug in my opinion. Thx –  user1435470 Nov 7 '12 at 21:11
    
@user1435470: not a bug at all. It's a security precaution by sshd so that only you (and root) can amend the file with allowed keys. The permissions on ~/.ssh also matter, btw. –  0xC0000022L Nov 15 '12 at 4:05
    
setting home and .ssh permissions to 750 don't fix this for me. I still can't "ssh localhost" without being asked for a password. I'd really like to so that I can use a Fabric script which configures servers to set up my local dev/test environment. –  Jonathan Hartley Apr 7 at 7:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.