Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have recently updated my java version to jdk7u9 in my ubuntu 11.04 Natty after which my previous maven projects have stopped working. I have installed using this script

When I run maven install in my projects (which previously used to work fine) I get this error

 org.apache.maven.lifecycle.LifecycleExecutionException: Error configuring: Reason: A required class was missing during mojo configuration: com/sun/tools/javac/util/Pair
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(

 Caused by: java.lang.ClassNotFoundException:

I have tried googling the issue but all i get is setting the JAVA_HOME variable which is correct. Can anybody please help?

My maven version 2.2.1

share|improve this question
You're running an unsupported configuration. I'd suggest getting rid of Horracle JDK, installing the latest openjdk-7-jdk package, and using that instead. – mirabilos Mar 1 '14 at 23:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.