Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
sudo apt-get autoremove appmenu-gtk appmenu-gtk3 appmen or sudo apt-get autoremove appmenu-gtk appmenu-gtk3 appmenu-qt.

I have used this command to remove the global menu in all installs of Unity. It works with all apps except Chrome and Firefox (even if you disable appropriate Add On in Firefox).

Any ideas how to fix this? I installed Unsetting, but that didn't work. Help!

share|improve this question

3 Answers 3

up vote 1 down vote accepted

This is now hidden in the Firefox Settings. Hhere is the fix:

  1. Type about:config in the Firefox search bar to enter settings
  2. Search for "menu" and find ui.use_unity_menubar
  3. Set this item to "false"

Voila! You get your attached menu back!

share|improve this answer

You need to remove the firefox-globalmenu package to disable firefox global menus. Sorry, I googled for a while and couldn't find a way to do this for chromium, which seems to have built-in support but no way of disabling it.

share|improve this answer
    
It was never an issue with 12.04 for Chrome or Chromium. I don't understand why it is now. Thank you for looking into it! –  chazdg Nov 7 '12 at 22:18
    
Unfortunately, that does not work for Firefox. I suspect the resolution is under my nose but I can't find it. ;( –  chazdg Nov 7 '12 at 22:27

As @Roger Rowlett said change true to false for Unity in about:config.

Global menu bar integration add-on missing in Firefox 22 for Ubuntu 12.04

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.