Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just ran a clean install of 12.10 on my sys76 laptop.

Time and date reads: 19:36 31 december 1969, even though it is: 13:29 07 november 2012.

I have it set for my location and it won't change manually, even tried in the command line with tz.

I think it is messing up the security certificates over the Internet cause I cannot change PPA over command line and going to Launchpad brings up the certificates page in Firefox.

Is this some known bug or is there a fix for it?

share|improve this question

Try:

sudo ntpdate ntp.ubuntu.com

Yes it would certainly mess with the SSL certs because they would be future-dated.

It doubt it's a bug in Ubuntu, your CMOS clock in the BIOS must have been set to that somehow.

share|improve this answer
    
18 Apr 15:06:04 ntpdate[29230]: no server suitable for synchronization found – vipin8169 Apr 18 at 10:36
    
after installing >> sudo apt-get install ntp>> 18 Apr 15:07:03 ntpdate[30070]: the NTP socket is in use, exiting – vipin8169 Apr 18 at 10:37

Just install ntp server:

sudo apt-get install ntp

It will automatically keep your clock synchronized.

share|improve this answer
    
This fixed the problem for me on Ubuntu 13.10. No idea why. (Problem was that the clock was off by one hour after daylight saving time/summer time took effect.) – Carl Apr 2 '14 at 8:40
    
I installed ntp however my time is still ahead by 5 minutes. How long does it take to update the time or do I need to run any command after? Thanks – Mo. Jul 12 '15 at 4:56

After installing 12.10 I had the same problem as well. Somehow the new installation set the BIOS clock to the year 2070 !! After this, Ubuntu wasn't able to set a different date both by ntp, manually, even using the date command.

Setting the right date in the BIOS settings solved the problem.

share|improve this answer

Install ntp and ntpdate executing the following commands-

sudo apt-get install ntp
sudo apt-get install ntpdate

Then, execute

sudo ntpdate ntp.ubuntu.com

This works for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.